Bug 357531 - INFO test always fails ABI check
INFO test always fails ABI check
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 22:10 EDT by Gary Case
Modified: 2008-07-16 17:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 07:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output.log (26.68 KB, text/plain)
2007-12-14 04:56 EST, Satyabrata Maitra
no flags Details

  None (edit)
Description Gary Case 2007-10-29 22:10:59 EDT
Description of problem:
The INFO test fails to run on the latest RHEL5.1 RC

Version-Release number of selected component (if applicable):

hts-5.1-8.el5

How reproducible:

Every time

Steps to Reproduce:
1. Install hts
2. Run 'hts plan'
3. Run 'hts certify --test info' or any other test that includes INFO, INFO will
fail.
  
Actual results:
Python traceback:
[root@localhost info]# hts certify --test info
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
running only test info 
running info on /org/freedesktop/Hal/devices/computer
make: Warning: File `testinfo.desc' has modification time 1.2e+04 s in the future
mkdir -p /tmp/hts-info-gARKHe/mnt/tests/HTS/hts/info
cp -a testinfo.desc runtest.sh info.py Makefile
/tmp/hts-info-gARKHe/mnt/tests/HTS/hts/info
install -m 0755 runtest.sh /tmp/hts-info-gARKHe/mnt/tests/HTS/hts/info
make: warning:  Clock skew detected.  Your build may be incomplete.
make OUTPUTFILE=/var/log/hts/runs/4/info/output.log RUNMODE=normal
UDI=/org/freedesktop/Hal/devices/computer DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./info.py
./runtest.sh
/tmp/hts-info-gARKHe/mnt/tests/HTS/hts/info/info.py
Running ./info.py:
OS Version RHEL5, kernel rpm kernel-2.6.18-53.el5
+ rpm -ql kernel-2.6.18-53.el5
Checking Kernel: PASS
Non-Red Hat kernel module ipw3945
Traceback (most recent call last):
  File "./info.py", line 282, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./info.py", line 266, in run
    success = self.checkModules()
  File "./info.py", line 121, in checkModules
    if self.osVersion is Constants.RHEL4 or not abiCheck(module):
NameError: global name 'abiCheck' is not defined
...finished running ./info.py, exit code=1
recovered exit code=1
hts-report-result info FAIL /var/log/hts/runs/4/info/output.log 
saveOutput: /var/log/hts/runs/4/info/output.log
Return value was 0

Expected results:

Successful INFO test

Additional info:
Comment 1 Greg Nichols 2007-10-30 10:53:18 EDT
I have a potential fix in R9.  Please try it out.
Comment 2 Gary Case 2007-10-30 14:10:18 EDT
-9 fails as well, but with different output. It seems to hinge on the supposedly
non-RH provided ipw3945 driver, which we do provide in the Supplemntary channel.

[root@dhcp243-68 ~]# modprobe ipw3945
[root@dhcp243-68 ~]# hts certify --test info
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
running only test info 
running info on /org/freedesktop/Hal/devices/computer
mkdir -p /tmp/hts-info-2BE1J_/mnt/tests/HTS/hts/info
cp -a testinfo.desc runtest.sh info.py Makefile
/tmp/hts-info-2BE1J_/mnt/tests/HTS/hts/info
install -m 0755 runtest.sh /tmp/hts-info-2BE1J_/mnt/tests/HTS/hts/info
make OUTPUTFILE=/var/log/hts/runs/2/info/output.log RUNMODE=normal
UDI=/org/freedesktop/Hal/devices/computer DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./info.py
./runtest.sh
/tmp/hts-info-2BE1J_/mnt/tests/HTS/hts/info/info.py
Running ./info.py:
OS Version RHEL5, kernel rpm kernel-2.6.18-53.el5
+ rpm -ql kernel-2.6.18-53.el5
Checking Kernel: PASS
Non-Red Hat kernel module ipw3945
Red Hat Enterprise Linux RHEL5 ABI
--------------------------------

Module: ipw3945
Kernel: 2.6.18-53.el5
Whitelist: /usr/src/kernels/2.6.18-53.el5-x86_64/kabi_whitelist

Error: Cannot read whitelist file
Error: Cannot read module file ipw3945
...finished running ./info.py, exit code=1
recovered exit code=1
hts-report-result info FAIL /var/log/hts/runs/2/info/output.log 
saveOutput: /var/log/hts/runs/2/info/output.log
Return value was 0
Comment 3 Rob Landry 2007-10-30 15:41:44 EDT
seems kernel-devel should be added to the deps list in some way since otherwise
we run into whitelist issues.
Comment 4 Greg Nichols 2007-10-30 19:44:12 EDT
Yes, it looks like hts needs to require kernel-devel.

Please install kernel-devel and retest.
Comment 5 Greg Nichols 2007-11-01 07:31:58 EDT
Fixed R11
Comment 6 Satyabrata Maitra 2007-12-14 04:56:23 EST
Created attachment 288981 [details]
output.log

Tested this bug in x86_64 system with RHEL5.1-Server. 
This bug is fixed now.

Version of Component tested :-
hts-5.1-18.el5
kernel-2.6.18-53.el5

Output.log file for hts info test is attached here with this comment.

Note You need to log in before you can comment on or make changes to this bug.