Bug 357671 - service stop doesn't kill all yum-updatesd processes.
Summary: service stop doesn't kill all yum-updatesd processes.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-30 07:50 UTC by Dave Jones
Modified: 2015-01-04 22:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 15:25:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Jones 2007-10-30 07:50:51 UTC
1. try to update packages from command line
2. fail because "Another app is currently holding the yum lock;"
3. service yum-updatesd stop
4. note that "Another app is currently holding the yum lock;" still.
5. ps ax |grep yum and note that yum-updatesd-helper is still running.
6. kill the pid
7. finally yum from the shell proceeds.

Comment 1 Jeremy Katz 2007-10-30 13:25:24 UTC
Indiscriminately killing the helper process is a good way to lead to hosed
rpmdbs if the user has configured yum-updatesd to automatically apply updates. 
So just killing it is the wrong thing to do.

Comment 2 Seth Vidal 2007-10-30 13:36:33 UTC
Maybe we should add a note to the shutdown command if the process is still locked.

So: if yum-updatesd is holding the yum lock output a 'process is running cannot
be shutdown safely' or somesuch message?



Comment 3 Seth Vidal 2008-03-12 15:25:18 UTC
We've switched yum to retry if it encounters a held lock.



Note You need to log in before you can comment on or make changes to this bug.