Bug 35774 - gnorpm goes in an infinite loop in the install dialog
gnorpm goes in an infinite loop in the install dialog
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-12 03:47 EDT by Sebastian Bach
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 19:21:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Bach 2001-04-12 03:47:13 EDT
Gnorpm goes in an infinite loop in the install dialog.
It's a local install, no network involved.
He displays all found packages in the known way (tree),
but he displays all packages infinite times and doesn't stop.


Reproducible: Always
Steps to Reproduce:
1. start gnorpm
2. push the install button
	

Actual Results:  infinite loop

Expected Results:  normal display of all found packages
Comment 1 Alan Cox 2001-05-03 10:34:16 EDT
Which version and what CD is mounted ?
Comment 2 Michael J. Kofler 2001-05-12 15:29:57 EDT
I'm having the same problem, using gnorpm-0.95.1.6.7x..
Hitting install does the same thing whether I'm looking to add RPMs from a CD or
just from the hard drive.
Comment 3 Jeff Johnson 2001-05-12 15:34:25 EDT
Can you hum a few notes about how to reproduce the problem? What packages
you're trying to install and the steps necessary to reproduce what be nice ...
Comment 4 Michael J. Kofler 2001-05-12 16:35:40 EDT
I start GnoRPM and enter the password to su for root priveleges. Gno-RPM loads
and I click "Install". The Install screen comes up and gives the normal tree
diagram of programs to install (from the basic CD that my version of red hat 7.0
came on, for example...although it does the same thing even if no CD is
mounted). The problem is that it keeps listing these RPMs over and over (i let
it run for a few hours one time just to see...all it did was eat system
resources and keep listing the RPMs over and over again). Even if no CD is
mounted, it does the same thing...it was giving me a list that just contained
Packages/Development/Libraries/python-xmlrpc-1.2.1-1 and Packages/System
Environment/Base/up2date-2.1.7-1 and up2date-gnome-2.1.7-1 in the default light
grey for Older Colour Packages.  
The filter Install is using is "All but installed packages"... I can't change it
until it finishes finding packages, which it never does. 
When a Cd is mounted it seems to loop it's findings of all the packages on the
CD.
Anything else?
-M
Comment 5 Michael J. Kofler 2001-07-24 15:50:27 EDT
Here's how to fix the problem:
Go to the Operations/Preferences menu of gnoRPM. 
Switch to the Install Window tab.
Edit the RPM directories at the bottom to just reflect the location of the 
RPMs you want to install (in our case it would have been 
/mnt/cdrom/RedHat/RPMS, and /mnt/cdrom/SRPMS if  you want the source code). 
Click Apply, then Ok. Now when you click the install button, it should work 
fine.
Comment 6 Michael J. Kofler 2001-07-26 19:21:55 EDT
The problem seems to be the addition of the user's home directory to the 
Install Window list. If this directory is listed, gnoRPM goes into the 
infinite loop.
Comment 7 Alexander Larsson 2001-08-02 14:11:07 EDT
In order to get the developers and maintainers of GnoRPM to look at this bug I
have moved it to the GnoRPM category in the Gnome bug tracker. It can be found
at http://bugzilla.gnome.org/show_bug.cgi?id=58459, where you can add yourself
to the cc-field if you want to recieve information about changes to the bug tatus.

Note You need to log in before you can comment on or make changes to this bug.