This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 3578 - BUG ID # none, patch on TI1225
BUG ID # none, patch on TI1225
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bootp (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-18 14:08 EDT by adavid
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-19 18:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adavid 1999-06-18 14:08:56 EDT
Sorry for the component choice, but there is no
cardmgr or pcmcia component. Anyway, this is at boot time:

The PCMCIA controller TI1225 is not in the compatibility
list. So it does not work at all under linux 2.0.36 with
the delivered pcmcia 3.0.5. But replacing with the 3.0.9
and patching some files very simply makes it work.

Curiously, it seems to work without patch with redhat 6.0
delivered with linux 2.2.5. I do not garantee
this since I have booted with the old 3.0.9 only once,
I'm not sure at all.

The point is: please patch pcmcia 3.0.9, put the card
in the compatibility list and update the boot images so
that this controller gets detected.

The patch is:

i82365.c:431:    { "TI 1225", IS_TI|IS_CARDBUS|IS_DF_PWR,
i82365.c:432:      PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_1225},
ti113x.h:56:#ifndef PCI_DEVICE_ID_TI_1225
ti113x.h:57:#define PCI_DEVICE_ID_TI_1225       0xac1c
ti113x.h:58:#endif

as you can see it is VERY simple, since the code
already handles this controller, without knowing it!
Just recognize it in the IDs, that's all! The card
manager is very well done indeed.

This message could have been "submitting an ID number for
the TI1225 controller" by the way.

Alexandre
Comment 1 Bill Nottingham 1999-08-19 18:05:59 EDT
this should be fixed in the Raw Hide installer.

Note You need to log in before you can comment on or make changes to this bug.