Bug 358 - DiskDruid incorrectly sees "0xf" Windows 95 extended partition
DiskDruid incorrectly sees "0xf" Windows 95 extended partition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-08 20:30 EST by Jeff Epler
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 16:18:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Epler 1998-12-08 20:30:46 EST
This Gateway PC has a 2MB /dev/sda1, ~7MB /dev/sda2 which is a Windows 95 extended partition, type 0xf.  Linux fdisk sees this correctly, and I was able to remove the NTFS partition inside and replace with three Linux partitions.
The installer then makes me reboot.  After the reboot I bypass the partitioning stage, but when I am asked to assign mount points, the DD interface still doesn't see the Linux partitions inside this 0xf extended partition.
Presumably removing the /dev/sda2 partition and replacing with a "normal" extended partition would make the installer happy, but what of NT?
Comment 1 David Lawrence 1998-12-09 16:18:59 EST
This is a bug in the disk druid portion of the install code which is
what you see when you are asked to assign mount points. The current
workaround is to use the linux fdisk utility and change the partition
type from Win95 Extended (type f) to Extended (type 5). This will
allow the install code to see the partitions correctly. You can then
leave it that way indefinitely or use fdisk at a later time to change
the partition back to type f. We are working on the install code to
allow it to work properly with this new partition type.
Comment 2 caspain 1998-12-17 01:15:59 EST
This problem might serious for some people.  I lost some data on one
of my partitions and I think I've figured out why:

I had an 8.4GB hard disk that had one 2.1GB FAT16 partition and one
2.1GB Win95 Extended partition (type 0F).  The Win95 Extended
partition contained a 2.1GB FAT16 partition.  (It's a silly way to set
it up, but that's the way it was.)  When I tried installing Linux, I
think Disk Druid couldn't identify the Win95 Extended partition and
decided that it was a primary partition.  I then set up three
additional Linux native partitions and a Linux swap.  Since there are
more than four partitions, some of these need to be in an extended
partition.  What happens when Disk Druid tries to create a second
extended partition?  I'm not sure.  I think what happened is that the
installer got confused and started writing data to the second FAT16
partition.  (Can it do that?)  As a result, it overwrote my data, made
the second FAT16 partition unreadable to Windows, and screwed up the
Linux installation.  While the installer was loading the packages onto
the drive it kept telling me that there was no space left on the
device.  A lot of this is speculation, but I've tried the entire
process on an brand new identical drive and the results are
consistent.

BTW, do you know the difference between Win95 Extended (0F) and
extended (05)?  0F is used for an extended partition if INT13
extension support is available.  I'm not sure if it makes a difference
though...

Note You need to log in before you can comment on or make changes to this bug.