Bug 3580 - Requires parsing broken in rpm-3.0.2-0.4
Requires parsing broken in rpm-3.0.2-0.4
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-06-18 15:34 EDT by Bill Nottingham
Modified: 2015-01-07 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-06-19 14:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 1999-06-18 15:34:10 EDT
If I have:
Requires: kernel >= 2.1.131, portmap

rpm -ba reports:
line 10: Version required: Requires: kernel >= 2.1.131,

Workaround: reorder the requires as:

Requires: portmap, kernel >= 2.1.131

This allows the build to complete successfully...
Comment 1 Jeff Johnson 1999-06-19 14:24:59 EDT
Fixed in rpm-3.0.2-0.5.

Note You need to log in before you can comment on or make changes to this bug.