Bug 358041 - 4 port ethernet card reduces pci bus performance
4 port ethernet card reduces pci bus performance
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
low Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 08:09 EDT by William Reich
Modified: 2009-07-06 09:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 09:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
4 port ethernet card picture (671.79 KB, image/jpeg)
2007-10-30 08:10 EDT, William Reich
no flags Details
sysreport information with 4 port ethernet card installed (1.21 MB, application/octet-stream)
2007-10-30 08:52 EDT, William Reich
no flags Details
sysreport with no cards (1.21 MB, application/octet-stream)
2007-10-30 09:44 EDT, William Reich
no flags Details
info on experimental kernel that worked fine... (1.13 MB, application/octet-stream)
2007-10-31 10:12 EDT, William Reich
no flags Details

  None (edit)
Description William Reich 2007-10-30 08:09:00 EDT
Description of problem:
We have our own pci card that does SS7 network protocols.
We have observed that we can perform a certain number of DMA
transactions per second.
When we add a 4 port ethernet card to the machine,
the performance of our SS7 degrades by 10 to 15%.
( No cables are connected to the ethernet card. )
When we pull the 4 port ethernet card out, performance is restored.

If we use a different ethernet card ( a 2 port card ),
there is no difference in performance in our ss7 board.

( attached is a picture of the 4 port ethernet card )

Version-Release number of selected component (if applicable):
redhat 4 64 bit update 4

( Please verify that I have assigned this to the correct component. )

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 William Reich 2007-10-30 08:10:50 EDT
Created attachment 243231 [details]
4 port ethernet card picture

picture of the 4 port ethernet card that is giving us trouble
with pci bus throughput
Comment 2 William Reich 2007-10-30 08:52:52 EDT
Created attachment 243301 [details]
sysreport information with 4 port ethernet card installed

sysreport information with 4 port ethernet card installed.
There is no ss7 board installed in the machine.
Comment 3 William Reich 2007-10-30 09:44:29 EDT
Created attachment 243351 [details]
sysreport with no cards

this sysreport is for the same machine, but
this time the 4 port ethernet card is not in the machine.
( so ss7 cards either )
Comment 4 Andy Gospodarek 2007-10-30 10:40:57 EDT
What you are observing is certainly interesting.  Do your SS7 card and the
4-port ethernet card share interrupts?

That 4-port card has been the topic of some fixes in the past and the e1000
driver in RHEL4 has gone through 2 major upgrades since 4.4 was released.  I'd
be curious to know how well the cards works with a later kernel.

If you are willing to at least experiment with one of my test kernels I would
appreciate it.  These are close to what will ship with 4.6 with a few extra
patches on top.

http://people.redhat.com/agospoda/#rhel4

Comment 5 William Reich 2007-10-30 12:40:57 EDT
I will try your test kernel.
Comment 6 William Reich 2007-10-31 09:15:48 EDT
I used the experimental 2.6.9-65-EL.gtest.33smp kernel.
My problem disappeared.
I observed no degradation in performance of my ss7 card.
( I ran the test twice with a reboot in between... )
( no cable connected to the quad ethernet network card. )

I will submit a sysreport for the historical record.
....

So, what do I tell my customers when they ask for a fix for this issue 
at their sites ?
Comment 7 William Reich 2007-10-31 10:12:28 EDT
Created attachment 244561 [details]
info on experimental kernel that worked fine...

This is a sysreport that shows information what
which kernel version was used for  a test
where a pci quad ethernet card no longer created a performance
degradation issue for a pci ss7 card.
( Both the quad ethernet card and the ss7 card are installed
in the machine at the time of this sysreport. )
Comment 8 William Reich 2007-10-31 10:33:53 EDT
Do you have any information as to whether or not this 
performance degradation issue exists in the RH 5 line ?
Comment 9 Andy Gospodarek 2007-10-31 10:59:10 EDT
As far as telling your customers, you can tell them to upgrade their kernels to RHEL4.6 when it is released (which should be quite soon).  The kernel you tested had some additional fixes that were not related to e1000, so the 4.6 kernel should be fine for e1000.
Comment 10 Andy Gospodarek 2007-10-31 11:03:47 EDT
I can't say for sure if RHEL5.0 will fix this issue since it contained basically the same driver as RHEL4.5.  A good indicator would be to try 2.6.9-55 on that RHEL4 system -- that driver should be quite similar to the driver we shipped in RHEL5.0.  The upcoming RHEL5.1 contains a driver version identical to RHEL4.6, so the problem will be fixed there when it is released (again, quite soon).
Comment 11 Andy Gospodarek 2009-07-06 09:15:08 EDT
Please reopen if this is not fixed in the current release (RHEL4.8).

Note You need to log in before you can comment on or make changes to this bug.