Bug 358051 - USB device still not properly recognized
USB device still not properly recognized
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-30 08:09 EDT by Ronny Fischer
Modified: 2008-05-18 17:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-18 17:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (23.01 KB, text/plain)
2008-01-18 06:17 EST, Ronny Fischer
no flags Details
lspci output (13.32 KB, text/plain)
2008-01-18 06:18 EST, Ronny Fischer
no flags Details
lsusb output (7.44 KB, text/plain)
2008-01-18 06:18 EST, Ronny Fischer
no flags Details

  None (edit)
Description Ronny Fischer 2007-10-30 08:09:59 EDT
Description of problem:
USB wireless adapter (Accton Tech ID 083a:4531) isn't correctly recognized by 
the system. At boot there occurs an error saying

usb 1-1: device descriptor read/all, error -71

which firstly appeared at Kernel 2.6.22-1.65 which is also described at https://

Version-Release number of selected component (if applicable):
Fedora 7, Kernel 2.6.23-1.10

How reproducible:

Steps to Reproduce:
1.F7, USB wireless adapter, and latest kernel
Actual results:
USB adapter not functional after startup

Expected results:
the opposite of the actual result should be!

Additional info:
Since the reslesase of 2.6.22-1.65 this error is on the plan, Until now four 
new kernel builds including one kernel update have been released and no one 
seems to care about that

The adapter works if the services network and wpa_supplicant are restartet 
(sometimes this must be done multiple times), so this is not a driver problem 
or has something to do with WPA via wpa_supplicant. This is an annoying bug in 
the kernel.

I beg you, please fix this ASAP

Comment 1 Christopher Brown 2008-01-15 22:08:20 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 2 Ronny Fischer 2008-01-16 13:46:01 EST
I have this bug still with the latest kernel of Fedora 7 ( 
This happens with all at boot time attached USB devices (mouse, wireless lan 
adapters, game adapters). While the mouse and the game adapter are working 
normally, the wireless adapter does not. As said before the services network 
and wpa_supplicant need to be restarted to work with it.

I found out that it has something to do with the DBUS-Interface, which doesn't 
recognizes the adapter properly in some way (I guess).

Comment 3 Christopher Brown 2008-01-16 14:49:47 EST
Okay, thanks for the update. Would you mind attaching the following as separate
attachments of type text/plain to this bug:

# lspci -vvxxx
# lsusb -vvxxx (you may need to install usb-utils)

I can then re-assign to the relevant maintainer who will be able to investigate
it further.
Comment 4 Ronny Fischer 2008-01-18 06:17:41 EST
Created attachment 292125 [details]
dmesg output
Comment 5 Ronny Fischer 2008-01-18 06:18:10 EST
Created attachment 292126 [details]
lspci output
Comment 6 Ronny Fischer 2008-01-18 06:18:44 EST
Created attachment 292127 [details]
lsusb output
Comment 7 Christopher Brown 2008-01-18 06:55:38 EST
Okay, thanks for that information. You might want to:

a) check if a BIOS update is available for your system
b) switch to the ath5k driver for your wireless chip as the ath_pci is no longer
maintained and is proprietary

You also appear to be running two wireless chips - one intel and one atheros.
Any reason for this?
Comment 8 Ronny Fischer 2008-01-18 15:19:47 EST
regarding your question:

a) Latest BIOS is installed

b) I'm sure the error has nothing to do with the madwifi driver for Atheros 
wireless adapters. The error itself also appeared on another system with 
different wireless adapter (there is also the latest BIOS installed).

You might wanna know that the Atheros adapter on this system is a PCMCIA 
adapter, so the USB subsystem isn't involved with that. There were no errors 
before the mentioned kernel version.

For me the ath5k driver isn't suitable for productive work yet and the adapter 
itself is only used in rare cases (e.g. connecting to 802.11a wireless 
networks). Most of the time it is detached from the system, because I'm using 
the integrated Intel adapter.

Also please take a look at <https://bugzilla.redhat.com/show_bug.cgi?id=242359> 
to see when this error arrived.

Thx in advance

Comment 9 Bug Zapper 2008-05-14 10:55:28 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Ronny Fischer 2008-05-18 11:05:42 EDT
The bug can be closed since the upgrade from Fedora 7 to Fedora 8 resolved the 


Note You need to log in before you can comment on or make changes to this bug.