Bug 358061 - Yum install i386 when it should not do so
Yum install i386 when it should not do so
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 08:11 EDT by Zdenek Kabelac
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from yum upgrade (4.38 KB, application/x-bzip)
2007-10-30 08:11 EDT, Zdenek Kabelac
no flags Details
Log of yum update for 2007-11-08 Fedore Devel machine (9.05 KB, application/x-bzip)
2007-11-08 06:52 EST, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2007-10-30 08:11:04 EDT
Description of problem:

Hi

I've tried to minimize the amount of i386 packages on my x86_64
system - however yum during 'yum update/upgrade' tries to put
.i386 libs back - I assume there is something wrong with
dependency calculations. 

I'm appending the log of my installation - where you can see
that kdemultimedia-lib.386 comes from non-identifiable package.
When I run yum update with exclude kdelibs.i386 - it went everything
just fine - and the following updated showed no needed update
even for kdelibs.i386


Version-Release number of selected component (if applicable):

I'm running fedora-devel - daily updated

How reproducible:

Unsure - probably install the same set of packages ??

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

To not see .i386 packages installed back over and over again ;)

Additional info:

Attached - yum install log - yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
installonly_limit=2
Comment 1 Zdenek Kabelac 2007-10-30 08:11:04 EDT
Created attachment 243241 [details]
Log from yum upgrade
Comment 2 Florian Festi 2007-10-31 14:35:49 EDT
This problem is caused by kdemultimedia-libs obsoleting kdemultimedia < own
version. Yum doesn't handle this case correctly but assumes that both 32bit and
64bit packages qualify as obsoletes for the installed 64bit kdemultimedia
package. This needs to be fixed in yum.
Comment 3 Zdenek Kabelac 2007-11-08 06:52:45 EST
Created attachment 251431 [details]
Log of yum update for 2007-11-08 Fedore Devel machine
Comment 4 Zdenek Kabelac 2007-11-08 07:00:07 EST
I've attached new log of today's update - as can be see inside the log (!!!!
marks my hand-written comment inside the log - to explain few details)
I had some problems with updating my x8_64 system that still contains couple of
i386 libs and I'm using exclude line in yum.conf to avoid poisoning of my
machine with unneeded libs & tools for i386.

I'm not sure what is the biggest problem here - I just name few:

- I couldn't easily update glib2 - unsure whether this is rpm/yum/glib2 fault
- even from command line I cannot override exclude of i386 package
- yum inserts i386 when it should not
- sometime strange dependency conflict requires --skip-broken
  (I'd like to not - the after this update next yum update did not want
   to update gecko-libs - and library has not been updated)
Comment 5 Florian Festi 2007-11-08 07:39:28 EST
If you still have a test case and are brave enough you can try yum HEAD ("git
clone http://linux.duke.edu/yum/git/yum.git"). It should behave better in such
situations. If it breaks you keep the pieces...
Comment 6 Florian Festi 2007-11-13 04:19:39 EST
It turns out that this problem is not yet fixed upstream. There are two
different patches that fix that problem that are already sent upstream. See
https://lists.dulug.duke.edu/pipermail/yum-devel/2007-November/004568.html and
follow ups.
Comment 7 Pavel Roskin 2007-11-13 13:02:43 EST
I've tested the improved version of the patch
(https://lists.dulug.duke.edu/pipermail/yum-devel/2007-November/004569.html),
and it's working properly with today's updates for Fedora 8.  With
yum-3.2.7-1.fc8, both kdepim-libs.i386 and kdepim-libs.x86_64 are trying to
replace kdepim.x86_64.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.