Bug 358161 - a failover of a nfs mount point does not occur if there is a process holding the filesystem even when force_umount option is enabled
Summary: a failover of a nfs mount point does not occur if there is a process holding ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-30 13:35 UTC by Marco Ceci
Modified: 2009-04-16 20:22 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 19:15:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fix the problem (5.60 KB, text/x-patch)
2007-10-30 13:35 UTC, Marco Ceci
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0791 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2008-07-25 19:14:58 UTC

Description Marco Ceci 2007-10-30 13:35:07 UTC
Description of problem:

A failover of a nfs mount point does not occur if there is a process holding the
filesystem even when force_unmount option is enabled. The netfs.sh script tries
to use "unmount -f" but this does not kill the processes that are holding the
filesystem.

Version-Release number of selected component (if applicable):

rgmanager-1.9.68.1

How reproducible:

always

Steps to Reproduce:

1. "cat > /nfs_mount" where "/nfs_mount" is a NFS mount point managed by
rgmanager where the force_unmount option is enabled
2. try to relocate the resource
  
Actual results:

the service relocate will fail because a process is holding the filesystem

Expected results:

rgmanager should kill the process and proceed with the unmount

Additional info:

Attaching a patch that fix the problem

Comment 1 Marco Ceci 2007-10-30 13:35:07 UTC
Created attachment 243341 [details]
patch that fix the problem

Comment 2 Lon Hohberger 2007-11-14 18:50:09 UTC
Patch applied to CVS

Comment 3 RHEL Product and Program Management 2007-11-30 19:05:13 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 errata-xmlrpc 2008-07-25 19:15:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0791.html



Note You need to log in before you can comment on or make changes to this bug.