Bug 35823 - LILO prompt "mem=" doesn't override lilo.conf "append="
LILO prompt "mem=" doesn't override lilo.conf "append="
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-12 14:49 EDT by Bowe Strickland
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-12 14:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2001-04-12 14:49:42 EDT
In seawolf, lilo.conf has 'append="mem=64M"', and I specified mem=96M at
the LILO 
prompt.  The kernel uses 64M instead.  I suspect the issue is in the
kernel's parsing of
command line arguments... it's taking the first instead of the last. 
Interestingly, you do 
not get similar behavior for "init=" kernel boottime parameter....

lilo.conf:
>> image=/boot/vmlinuz-2.4.2-2
>>	label=linux
>>	read-only
>>	root=/dev/hda5
>>	append="mem=64M"

lilo prompt:
LILO: linux mem=96M

cat /proc/cmdline:
BOOT_IMAGE=linux ro root=305 BOOT_FILE=/boot/vmlinuz-2.4.2-2 mem=64M
mem=96M

cat /proc/meminfo | head -4:
>>        total:    used:    free:  shared: buffers:  cached:
>> Mem:  64151552 31064064 33087488        0  2748416 16683008
>> Swap: 139788288        0 139788288
>> MemTotal:        62648 kB
Comment 1 Arjan van de Ven 2001-04-12 15:59:40 EDT
The kernel parses both and takes the smallest to be safe...
Fix your lilo.conf ;)

You should not need any mem= line with our kernel now anyway.

Note You need to log in before you can comment on or make changes to this bug.