Bug 35824 - Enterprise kernel hangs system with 8GB of memory (seawolf)
Enterprise kernel hangs system with 8GB of memory (seawolf)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-12 15:23 EDT by Mark Rusk
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 15:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ksymoops from magic sysreq dump (34.50 KB, text/plain)
2001-04-12 15:29 EDT, Mark Rusk
no flags Details

  None (edit)
Description Mark Rusk 2001-04-12 15:23:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.2-0.1.32 i686)


When running Cerberus tests on an 8-way with 8gb of memory, system hangs
within 10 minutes of start of testing with enterprise kernel.  System has
16gb of swap.

Reproducible: Always
Steps to Reproduce:
1.Load 7.1
2.start cerberus
3. wait 10 minutes
	

Only "magic" sysrq key works.  I will attach a ksymoops output.
Comment 1 Mark Rusk 2001-04-12 15:29:15 EDT
Created attachment 15264 [details]
ksymoops from  magic sysreq dump
Comment 2 Michael K. Johnson 2001-04-13 13:32:12 EDT
This is a deadlock involving zone pressure when dealing with bounce buffers.
It will only occur with the enterprise kernel, and then only on machines
containing memory with physical addresses above 4GB.  We are investigating.

The amount of time it takes to reproduce this is variable.  It happens only
under a combination of extreme IO load and extreme memory pressure.
Comment 3 Matt Domsch 2001-04-16 18:33:46 EDT
Since this is a sev-1 bug with the gold CDs, can we move this out of the beta 
team to public?
-Matt
Comment 4 Matt Domsch 2001-07-11 15:35:05 EDT
Resolved in SBE kernel 2.4.3-6, therefore also in errata kernel 2.4.3-12.  
Closing.

Note You need to log in before you can comment on or make changes to this bug.