Bug 3583 - Not Recognizing Laptop CD-Roms on Install
Not Recognizing Laptop CD-Roms on Install
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Depends On:
  Show dependency treegraph
Reported: 1999-06-18 17:19 EDT by Phil Salkie
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Phil Salkie 1999-06-18 17:19:38 EDT
System is a 200 MhZ IBM Thinkpad, can have either floppy or
cd-rom installed, not both.  Tried to install from CD-Rom by
invoking loadlin from the /dostools directory under Win95
Dos.  Loadlin started up, linux booted, recognizing CD-Rom
as HDB, install script started.  When "Insert CD-Rom" prompt
came up, script was unable to recognize CD-Rom.  Workaround
turned out to be ejecting and re-closing the CD several
times quickly after hitting ENTER, to keep the disc
spinning.  Then the system recognized the CD and started
running.  I had seen similar behavior on an external PCMCIA
CD-Rom and Linux 5.1 install - if the disc isn't spinning,
the install doesn't leave enough time for things to spin up
from their powerdown state before timing out and saying that
the disc isn't there.

The interesting thing is that it never seems to come up
again - the CD seems to mount and unmount after
installation is complete and not give any trouble
thereafter, but I'm unsure how it can be a problem with the
install script...

Comment 1 David Lawrence 1999-06-22 14:23:59 EDT
Is the drive a standard ATAPI internal hard drive? Also can the BIOS
be setup to allow the laptop to boot directly to the CD instead of
having to run the autoboot.bat script?

------- Email Received From  Phil Salkie <phil@howman.com> 06/23/99 09:50 -------
Comment 2 Michael K. Johnson 1999-07-13 14:15:59 EDT
This may be related to booting from CD and the CD being active
when the built-in atapi cdrom code probes; you are probably
forcing a re-probe of some sort when you open and close the drive
at mount time.  The kernel messages on VC 4 at mount time (press
alt-f4 directly after doing the eject/insert dance) might give us
some clues to whether this conjecture is correct...
Comment 3 Phil Salkie 1999-08-15 22:58:59 EDT
Re:  Problems with Red Hat installations using laptop ATAPI cd-rom

I had originally reported the problem on a ThinkPad, but I've been
unable to get my mitts on the original machine.

I had seen the same symptoms on a PCMCIA CD-ROM, and I've duplicated
the problems on it using my AST Ascentia 950N.

This is the trace of loading the card and socket services during
install when the CD-ROM drive is NOT kept spinning by opening and
closing the drive door: (I had to type this in off the laptop screen,
hope I got it all correct...)

It's pretty touchy to get it to work right - I've tried several times
tonight, and have yet to get anything other than what I'm showing
here, but I did get it working with the 5.2 install using the old
open-and-close trick.


<6>Linux PCMCIA Card Services 3.0.9
<6>  kernel build: 2.2.5-`4BOOT #1 Sun Apr 18 22:58:51 EDT 1999
<6>  options:  [pci] [cardbus]
<6>Intel PCIC probe:
<6>  Cirrus PD672x ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
<6>    host opts [0]: [ring] [65/6/0] [1/15/0]
<6>    host opts [1]: [ring] [65/6/0] [1/15/0]
<6>    ISA irqs (default) = 3,4,5,7,9,10,11,12 polling interval = 1000
<30>Aug 15 21:55:50 cardmgr[13]: starting, version is 3.0.8
<30>Aug 15 21:55:50 cardmgr[13]: watching 2 sockets
<30>Aug 15 21:55:50 cardmgr[13]: Card Services release does not match!
<6>cs: IO port probe 0x1000-0x17ff: excluding 0x1028-0x102f
0x1378-0x137f 0x1388-0x138f 0x13f0-0x13ff 0x1428-0x142f 0x1620-0x162f
0x1778-0x177f 0x1788-0x178f 0x17f0-0x17ff
<6>cs: IO port probe 0x100-0x4ff: excluding 0x220-0x22f 0x378-0x37f
0x388-0x38f 0x428-0x42f
<6>cs: IO port probe 0xa00-0xaff: excluding 0xa20-0xa2f
<30>Aug 15 21:55:50 cardmgr[13]: Socket 1: EXP Traveler 620 CD-ROM
<30>Aug 15 21:55:50 cardmgr[13]: executing: 'insmod
<4>hdc: PCMCIA Portable CD-ROM, ATAPI CDROM drive
<4>ide1 at 0x320-0x327,0x32e on irq 3
<4>hdc: ATAPI 8X CD-ROM drive, 120kb Cache
<6>Uniform CDROM driver Revision: 2.54
<6>ide_cs: hdc: Vcc = 5.0, Vpp = 0.0
<30>Aug 15 21:55:53 cardmgr[13]: executing './ide start hdc'
<30>Aug 15 21:55:53 cardmgr[13]: + cat: not found
<30>Aug 15 21:55:53 cardmgr[13]: + ./ide: /sbin/ide_info: not found
<30>Aug 15 21:55:53 cardmgr[13]: + usage: ./ide [action] [device name]
<30>Aug 15 21:55:53 cardmgr[13]: +   actions: start check stop suspend
<30>Aug 15 21:55:53 cardmgr[13]: start cmd exited with status 1

Inserting and removing the PCMCIA card causes the modules to unload
and load again, sometimes getting the line:

<4>hdc: no response (status = 0xd0), resetting drive

after the line about insmod ide_cs.o

When the PCMCIA card is inserted, there's a delay of several seconds
before the CD spins up, and before this happens, the module gives a
bass beep (as in card load has failed) and sometimes prints the 'no
response' line.

Here's one spot I think the module should wait considerably longer,
butthat's obviously not the problem with the ThinkPad installation,
as the ThinkPad is straight ATAPI right on the internal controller,

(but it does still have the delay before the disk spins up, so maybe
the ATAPI cd-rom module has a similar problem of timing out too


* calling mount(/tmp/fd0, /tmp/floppy, ext2, -1058209791, (nil))

* removing device file /tmp/fd0

* mounting ram2 on /tmp/pcmcia as type ext2

* creating directory on /tmp/pcmcia rc=0

* calling mount(/tmp/ram2, /tmp/pcmcia, ext2, -1058209791, (nil))

* removing device file /tmp/ram2

* running: /bin/insmod /bin/insmod /modules/pcmcia_core.o

* running: /bin/insmod /bin/insmod /modules/i82365.o

* running: /bin/insmod /bin/insmod /modules/ds.o

After this, the dialog box comes up asking what type of CDROM do you
have, and allowing only 'SCSI' and 'Other CDROM' as choices, neither
of which is correct.

BTW, backing up into the PCMCIA Support screen makes the system
attempt to mount a ramdisk on top of an already mounted ramdisk,
causing a forced shutdown and (obviously) abort of the install.

Also, shouldn't ALT-F2 get me to a shell?  It doesn't seem to do
anything in this install...

Note You need to log in before you can comment on or make changes to this bug.