Bug 358341 - SDL_mixer causes Battle for Wesnoth to hang on load menu.
SDL_mixer causes Battle for Wesnoth to hang on load menu.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL_mixer (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 11:09 EDT by charles harris
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.8-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 10:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles harris 2007-10-30 11:09:07 EDT
Description of problem:
Hang when trying to load saved game.

Version-Release number of selected component (if applicable):
wesnoth-1.2.7-1.fc8

How reproducible:
Don't know. Will try again. I don't have any problems with same version running
on fc7.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 charles harris 2007-10-30 14:51:42 EDT
A hang can be reliably produced by clicking on quit. Wesnoth then takes up 50%
processor (on core 2), and just sits there as the fan revs up. I would consider
this bug a blocker ;)
Comment 2 Brian Pepple 2007-10-30 18:54:27 EDT
Are you running Pulse Audio by chance?

I've had some people on IRC check on this since I don't have access to a Rawhide
machine until I get home.  No one could reproduce this bug, but none of them
were running Pulse Audio.
Comment 3 charles harris 2007-10-30 19:20:08 EDT
How do I tell? There is a lot of pulseaudio stuff

$[charris@f8 ~]$ rpm -qa | grep audio
audiofile-0.2.6-7.fc8
pulseaudio-utils-0.9.7-0.16.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.16.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.16.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.16.svn20071017.fc8
pulseaudio-libs-0.9.7-0.16.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.16.svn20071017.fc8
gnome-audio-2.0.0-4
pulseaudio-0.9.7-0.16.svn20071017.fc8
audiofile-devel-0.2.6-7.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-esound-compat-0.9.7-0.16.svn20071017.fc8

but lsmod doesn't show any pulse audio loaded. Another thing, probably
unrelated, is that BfW comes up full screen, but the map only fills up part of
the screen real state. That doesn't happen in fc7 running on the same hardware
and with the same version of BfW. I'll boot up fc7 and see what the audio is.
Comment 4 charles harris 2007-10-30 19:34:05 EDT
There do seem to be problems with pulseaudio, I found the following at the tail
of the system log:

Oct 30 17:24:16 f8 pcscd:last message repeated 4 times
Oct 30 17:24:16 f8 gdm-binary[6487]: WARNING: gdm_slave_xioerror_handler: Fatal
X error - Restarting :0
Oct 30 17:24:27 f8 pulseaudio[13692]: pid.c: Stale PID file, overwriting.
Oct 30 17:24:27 f8 pulseaudio[13692]: alsa-util.c: Cannot find mixer control
"Master".
Oct 30 17:24:27 f8 pulseaudio[13692]: alsa-util.c: Cannot find fallback mixer
control "PCM".
Oct 30 17:24:28 f8 gconfd (charris-6582): Resolved address
"xml:readwrite:/home/charris/.gconf" to a writable configuration source at
position 0
Oct 30 17:24:28 f8 hcid[2497]: Default passkey agent (:1.64, /org/bluez/passkey)
registered
Oct 30 17:24:28 f8 hcid[2497]: Default authorization agent (:1.64,
/org/bluez/auth) registered
Oct 30 17:24:28 f8 pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0 Not Found

This might be related to the installation problems I had -- unbootable kernel,
failed X necessitating text install, etc, etc. -- maybe something didn't get set
up quite right.
Comment 5 Brian Pepple 2007-10-30 19:43:07 EDT
Warren Togami ran into problems also w/ Wesnoth, and the problem does appear to
be related to Pulse Audio.  Hopefully, we should be able to fix this by using
pasuspend, but I'll need to verify that solution when I get home.
Comment 6 Brian Pepple 2007-10-30 21:18:22 EDT
Reassigning to SDL_mixer, since SDL lockups with pulseaudio.   A temporary hack
in SDL_mixer-1.2.8-4 should fix this until SDL supports pulseaudio directly. 

http://koji.fedoraproject.org/koji/buildinfo?buildID=22975
Comment 7 charles harris 2007-10-30 22:38:28 EDT
Wesnoth still hangs on quit with the same log messages. Here are the SDL*
versions on my system

$[charris@f8 ~]$ rpm -qa | grep SDL
SDL-1.2.12-2.fc8
SDL_image-1.2.6-3.fc8
SDL_mixer-1.2.8-4.fc8
SDL-devel-1.2.12-2.fc8
SDL_net-1.2.7-3.fc8
Comment 8 charles harris 2007-10-30 22:43:20 EDT
Oops, disregard. It took a second startup before the new SDL_mixer was found.
Works now, along with sound.
Comment 9 Brian Pepple 2007-10-30 23:06:53 EDT
(In reply to comment #8)
> Oops, disregard. It took a second startup before the new SDL_mixer was found.
> Works now, along with sound.

Be aware running this multiple times, may crash pulse audio for you, but I
believe we are going to tag a new release of Pulse Audio for tomorrow that
should prevent that.  http://koji.fedoraproject.org/koji/buildinfo?buildID=22974

Note You need to log in before you can comment on or make changes to this bug.