Bug 358491 - [RHEL5] evolution does not show recurrence of accepted meeting invites
[RHEL5] evolution does not show recurrence of accepted meeting invites
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 12:07 EDT by Lars Herrmann
Modified: 2008-05-21 11:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0361
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed evo patch (4.20 KB, patch)
2008-01-16 11:06 EST, Milan Crha
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 509923 None None None Never

  None (edit)
Description Lars Herrmann 2007-10-30 12:07:37 EDT
Description of problem:
If you accept a meeting invite (ics attachment) in evolution that contains
recurrence, evolution will store the event in the users calendar as expected,
but will not show the recurrening events. evolution writes the ics file
(~/.evolution/calendar/local/system/calendar.ics) with recurrence, but does not
show it in calendar component, for example:

BEGIN:VEVENT
UID:20071030T155131Z-3502-4056-1-14@schaller.csb
DTSTAMP:20071030T155243Z
DTSTART;TZID=/softwarestudio.org/Olson_20011030_5/Europe/Berlin:
 20071030T100000
DTEND;TZID=/softwarestudio.org/Olson_20011030_5/Europe/Berlin:
 20071030T123000
TRANSP:OPAQUE
SEQUENCE:3
SUMMARY:test / Breakfast meeting
CLASS:PUBLIC
CREATED:20071030T155542
LAST-MODIFIED:20071030T155542
RECURRENCE-ID:20071030T100000
ORGANIZER;CN=Ingrid Schaller:MAILTO:schaller@redhat.com
ATTENDEE;CUTYPE=INDIVIDUAL;ROLE=REQ-PARTICIPANT;PARTSTAT=ACCEPTED;
 RSVP=TRUE;CN=Ingrid Schaller;LANGUAGE=en:MAILTO:schaller@redhat.com
ATTENDEE;CUTYPE=INDIVIDUAL;ROLE=REQ-PARTICIPANT;RSVP=TRUE;CN=Lars 
 Herrmann;LANGUAGE=en;PARTSTAT=ACCEPTED:MAILTO:herrmann@redhat.com
RRULE:FREQ=DAILY;INTERVAL=2
X-MICROSOFT-CDO-REPLYTIME:20071030T155542Z
BEGIN:VALARM
X-EVOLUTION-ALARM-UID:20071030T155537Z-2985-3627-1-9@x31.sulz
ACTION:DISPLAY
TRIGGER;VALUE=DURATION;RELATED=START:-PT10M
END:VALARM
END:VEVENT
END:VCALENDAR


Version-Release number of selected component (if applicable):
evolution-2.8.0-33.0.1.el5

How reproducible:
send meeting invite with recurrence to evolution user, accept meeting, check
calendar


  
Actual results:
event is stored in users calendar, but only the first occurence shown.
This is misleading both users involved: the sender receives an email stating
accpetance and the receiver does not know about the recurrence.

Expected results:
show event with recurrence

Additional info:
As evolution is heavily user internally at Red Hat, this should be fixed with
high priority
Comment 2 RHEL Product and Program Management 2007-10-30 13:04:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Milan Crha 2008-01-16 11:06:08 EST
Created attachment 291862 [details]
proposed evo patch

I found out that the event is just the instance, and not the master object of
the event, so it is recurring, but is stored as an exception of the master
object. The problem was with the Evolution, it sent always the event instance,
except when creating new meeting.

This patch will send changes based on the modify mode chosen by user (the
dialog which asks what to modify, all instances or only this instance).
Comment 9 Milan Crha 2008-01-16 11:07:19 EST
I also moved this upstream, see [1] for more details.
[1] http://bugzilla.gnome.org/show_bug.cgi?id=509923
Comment 10 Matthew Barnes 2008-01-18 14:29:07 EST
Hmm, I'm still able to reproduce the problem with the patch applied, although it
took several tries for the event to even show up.  Marking this MODIFIED anyway;
I think we can still figure this out before 5.2 ships.

Patch applied to evolution-2.12.3-2.el5
Comment 14 errata-xmlrpc 2008-05-21 11:18:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0361.html

Note You need to log in before you can comment on or make changes to this bug.