Bug 358541 - intel video suspend/resume palette problem
intel video suspend/resume palette problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 12:32 EDT by Michael E Brown
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 05:01:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (1.24 KB, text/plain)
2007-10-30 21:26 EDT, Michael E Brown
no flags Details
Post-resume Xorg.0.log (44.38 KB, text/plain)
2007-10-30 21:32 EDT, Michael E Brown
no flags Details

  None (edit)
Description Michael E Brown 2007-10-30 12:32:38 EDT
Description of problem:

Suspend/resume problem with 'intel' video driver. Does not appear to happen with
'i810' driver. Occurs on Dell D620 laptop (tested), probably other models as
well. Intel 945GM graphics.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)


Upon resume, the display is 'darker'. The longer you suspend the machine for,
the 'darker' the display is. What is interesting is that the backlight is at the
correct brightness, it looks like the palette is not being restored correctly.
All colors on the screen are shifted towards black. After about 1 hour of
suspend, upon resume, the display almost looks as if it is completely black, but
if you carefully observe you can see the screen. Another interesting thing is
that it affects both internal LCD display as well as external VGA display by the
same amount. Tried 'xrandr' to enable/disable displays, but that has no effect.
restarting X fixes it.


Version-Release number of selected component (if applicable):

xorg-x11-drv-i810- 2.0.0-4.fc7.x86_64

How reproducible:

Reproduces every time for me.

Steps to Reproduce:
1. suspend machine
2. wait
3. resume
  
Actual results:

dark screen.

Expected results:

same screen that was there when suspend.

Additional info:
Comment 1 Michael E Brown 2007-10-30 13:18:13 EDT
Running on a D620 with Intel Core2 Duo running SMP kernel:

Linux duo 2.6.22.9-91.fc7 #1 SMP Thu Sep 27 20:47:39 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux
Comment 2 Matěj Cepl 2007-10-30 13:44:20 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Michael E Brown 2007-10-30 21:25:25 EDT
The issue will not reproduce without an xorg.conf because the system
 A) defaults to i810 driver
    and
 B) wont even start unless you use 915resolution

Attaching the xorg.conf that I normally run, as well as Xorg.0.log
Comment 4 Michael E Brown 2007-10-30 21:26:15 EDT
Created attachment 243931 [details]
xorg.conf
Comment 5 Michael E Brown 2007-10-30 21:32:06 EDT
Created attachment 243971 [details]
Post-resume Xorg.0.log

This is the log from after the system has resumed.
Comment 6 Michael E Brown 2007-10-31 05:01:43 EDT
This looks like it may have been a kernel problem...

I upgraded to the latest F7 update kernel (2.6.23) that came out today, and can
no longer reproduce this issue. Booting back to the old 2.6.22 kernel reproduces it.

You must suspend for ~20-30 mins to reproduce the problem with the older kernel.

Closing...
Comment 7 Matěj Cepl 2007-10-31 13:24:10 EDT
better resolution.

Note You need to log in before you can comment on or make changes to this bug.