Bug 35858 - Memory Loss
Summary: Memory Loss
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-13 04:55 UTC by Need Real Name
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-15 03:46:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-04-13 04:55:27 UTC
I have a clean install of RH Wolerine installed and using kernel Linux
version 2.4.1-0.1.9. I noticed when running gnome that I kept loosing
memory. I have 160mb ram installed. When I start gnome I had 100mb free.
Then after running netscape, or any other application I ran down to 1mb
free. It starts paging and performance is reduced. I upgraded to 256mb.
Before I started gnome I had 200mb free. It drops to 2mb then starts paging
again. I tried not using any types of guis, and stuck to command line for
various tasks, and noticed that free memory still drops.

Comment 1 Ed McKenzie 2001-04-15 03:46:48 UTC
You should upgrade to 2.4.2-0.1.49. It fixes most of the performance problems in
the original Wolverine kernel.

Comment 2 Trond Eivind Glomsrxd 2001-04-18 19:33:01 UTC
1) "free" isn't a good indicator for many, as they aren't aware of Linux wanting
to use as much as possible as cache - so if you run a program on a fresh system
an exit t, free will report a lower number than before: It has the program in cache.
Cache is freed when needed for programs - the kernel dynamically adjusts to
provide the best performance

2) The kernel has been updated since then, and has much better performance.


Note You need to log in before you can comment on or make changes to this bug.