Bug 35859 - OUTPUT_CHARSET is not set for Japanese mode
Summary: OUTPUT_CHARSET is not set for Japanese mode
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-13 06:37 UTC by Bill Huang
Modified: 2005-10-31 22:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 07:11:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Huang 2001-04-13 06:37:26 UTC
Since OUTPUT_CHARSET=EUC-JP is not set in env,
some Japanese help can't be displayed on console or gnome-terminal.
such as gpg --help.

Comment 1 Nakai 2001-04-13 06:56:55 UTC
This problem should be fixed in Anaconda, shouldn't it?

Comment 2 Matt Wilson 2001-04-13 15:29:33 UTC
Applications that output characters in a locale that isn't POSIX *must* call
setlocale()


Comment 3 Bill Nottingham 2001-04-13 16:13:59 UTC
So, you're saying this is an app problem and not an initscripts problem?

Comment 4 Matt Wilson 2001-04-13 16:30:06 UTC
absolutely.  If you set OUTPUT_CHARSET this will override the charset used in an
application that uses setlocale() properly.  This means that if you set
OUTPUT_CHARSET to EUC-JP and then run a properly written program using
LANG=de_DE it will not display properly.


Comment 5 Bill Nottingham 2001-04-13 22:11:04 UTC
OK, assigning to gpg.

Comment 6 Nakai 2004-05-06 07:11:18 UTC
Obsoleted.


Note You need to log in before you can comment on or make changes to this bug.