Bug 3586 - Netscape 4.08/4.5/4.6/4.61 memory leak & crashing in Redhat 6.0
Netscape 4.08/4.5/4.6/4.61 memory leak & crashing in Redhat 6.0
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-18 19:53 EDT by dsp
Modified: 2014-03-16 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-18 17:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsp 1999-06-18 19:53:45 EDT
I submitted the following question to comp.os.linux.x, and
found I'm not the only person to experience this:

I've been having a problem with Netscape crashing using
versions 4.08/4.51/4.6 and 4.61, usually on pages with
forms.  This doesn't appear to be Java or javascript
problem, nor does the fontpath fix for RH6 solve the
problem.

This problems shows itself most often with
the 'composition' form for hotmail.

Netscape appears to use more and more memory, causing the
computer to thrash on the HD, making it virtually
impossible to use the keyboard, to open a new terminal, or
to login at another prompt to kill Netscape.  Sometimes I
can login over the network and kill it remotely, and
sometimes not.  Top shows netscape eating more and more
memory.

It almost always results in my waiting for 15 minutes and
then forcibly rebooting.  If I allow it continue, it will
(eventually) crash netscape.


My configuration:

Redhat 6 (glibc 2.1)
2.2.7 Kernel (not the RH kernel - the 'normal' kernel
configured and built
for this system)
Gnome (latest RPMS)
Enlightenment
Abit BH6 / Celeron 300a (Yes, overclocked, but that's not
the problem! :)  )
64M SDRAM
Riva TNT (using XF86SVGA)
XFree86 3.3.3.1

Just to make things more complicated:
I've had this problem with other WMs, including Afterstep.
As I said above, this doesn't seem to be a Java problem.
(I don't even
think some of the pages involved use javascript.)
It is intermittent -- It happens at least once a week, but
not every time
you go to these pages.

I got the following responses from others in the
comp.os.linux.x newsgroup:
"For what it's worth, I have _exactly_ the same behavior,
although on my system the disk thrashing is almost
inevitable (rather than intermittent) since I run with 32
MB of RAM and an equivalent amount of swap.  And like you,
I had this problem with 5.2 as well.  And like your wife,
the worst culprit is definitely the Hotmail composition
page!  "

"I wonder whether your problem is caused by your window
manager. I tried RedHat 5.2 on a Sparc machine.  It behaved
just like you described.  After I switched to a lesser
resources demanding window manager, all of the crashing are
gone.  I am using Blackbox as my wm now."
Comment 1 jszabo 1999-07-02 13:31:59 EDT
I am in the habit of running top just to see if there are any netscape
processes running eating a lot of cpu.  They can only be killed with
-9.  It seems to happen less often with 4.61, and on pages with java
that have been cached and visited before.  www.freshmeat.net uses to
always shut down netscape, but not these days.
Comment 2 dsp 1999-07-21 23:35:59 EDT
I ran Netscape 4.61 w/ strace, and artificially 'forced' a crash -- I
went into the hotmail composition and held down serveral keys until I
had a long (but not excessive) message and it crashed.  I have both a
core file and a copy of the strace output.  Netscape didn't act
exactly as it does normally with this problem:  this time it crashed
(and took X down with it) relatively quickly, while normally it eats
more and more memory, making it impossible to even to type, to get a
terminal to kill it, or do anything else, but takes as long as 30
minutes to completely crash before returning control to the user.

Gzipd the core and strace are about 140K -- should I send them
somewhere?  where?

David
Comment 3 wilburn 1999-07-29 13:16:59 EDT
I have also seem this problem on 3 machines:

RH6.0, i386
gnome+enlightenment (various versions, stock to latest stable)
netscape 4.6,4.51

problem is not consistently reproducable, but seems to occur on long
form pages after using pull-down menu - can no longer enter text after
this occurs.

The previous two submitters seem much more knowlegable, but I'll be
glad to provide more information, if useful.

Scott
Comment 4 Bill Nottingham 1999-08-18 17:39:59 EDT
submitted to netscape; they will have to provide a fix.

Meanwhile, you might try running as:

LD_LIBRARY_PATH=/usr/i386-glibc20-linux/lib \
/usr/i386-glibc20-linux/lib/ld-linux.so.2 \
/usr/lib/netscape/netscape-communicator
Comment 5 almuse 1999-08-19 12:23:59 EDT
I have the same problem with RH6.0, icewm(very small window
manager) and Netscape Communicator 4.6. Is it just a netscape
mistake?

Note You need to log in before you can comment on or make changes to this bug.