Bug 35866 - Installer crashing in mounting stage
Installer crashing in mounting stage
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 05:11 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 16:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-13 05:11:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


Installing into disk that already has some partitions. Choosing custom 
setup, existing partitions.Getting dump.

Reproducible: Always
Steps to Reproduce:
1.Custom setup
2.Choosing already defined partitions (as 83 - linux native), there are 
some more partitions (choosed not mount) - ntfs.
3.formating
	

Actual Results:  dump/reboot

Expected Results:  RedHat7 linux installed

the same with RedHat6.2 
Mandrake 7.2 installs fine.
problem dont exist, when no more partitions defined as ntfs in Partitions 
table and doing standart (Workstation or Server) instalation.
I can format new linux partitions from redhat6.2 (installed in another 
partition), o mandrake7.2, choosing not format partittion from installer - 
getting the same error

THIS IS _NOT_ DUBLICATED FROM 18032 -
tried updated anaconda with update-disk-20001009.img

anaconda dump :
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 1491, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/tmp/updates/fstab.py", line 722, in mountFilesystems
    isys.mount('/proc', instPath + '/proc', 'proc')
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (20, 'Not a directory')

Local variables in innermost frame:
fstype: proc
location: /mnt/sysimage/proc
readOnly: 0
device: /proc

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-04-16 23:32:06 EDT
Are you sure that you selected the partitions you created to be formatted?  We
have seen this bug two other times (bug #18168 and bug #20838), but both times
the users quit responding before we found out how to reproduce it.  Any linux
partitions that you are going to be writing data to *must* be formatted first,
or else the installer will crash while trying to write data to an unformatted
partition.

As a side note, we released Red Hat Linux 7.1 today.  I'm curious to know if 7.1
fixes your problem because we have done a good bit of work with the way the
installer handles mounting, formatting, and partitioning.  If you don't have the
bandwidth to download it easily, that's ok.
Comment 2 Need Real Name 2001-04-17 02:52:32 EDT
Yes, I'm sure I selected to format.
Maybe problem caused by existing ntfs partitions - disks -
hda  - 45G IBM DTLA
hda1 - 4G - ntfs
hda2 - 5G - ext2 - Mandrake 7.2 installed (after numerous of trying RedHat 6.2 -
 7)
hda3 - 5G - ext2 - where still trying to install RedHat7
hda4 - extended - 31G
hda5 - 10G ntfs
hda6 - 10G ntfs
hda7 - 510M linux swap
hda8 - 8G ntfs

hdb  - 6G Seagate
hdb1 - 5,6 G ext2 - RedHat6.2
hdb2 - 400 M  linux swap

computer - MB MSI 6337 (i815e pro) 512M RAM, 866 PIII copermine, matrox g400

For the first time I could install rhat7.
No reinstall was succesfull. 

Disk/controller is ok, cause I can format/mount hda2/3 from 
rhat6.2/Madrake7.2/WinNT


Comment 3 Brent Fox 2001-04-20 11:38:16 EDT
I'm not quite sure what the problem is here.  Perhaps your cd is bad or
something went wrong during the download.  The installer is trying to mount the
/proc directory on your root partition, and it is not able to do that for some
reason. I'm almost certain that this issue has been fixed in 7.1 with the
stricter partitioning rules.
Comment 4 Need Real Name 2001-04-23 02:30:44 EDT
I'm sure about cd/download - 
1. tested on 3 CD got by 3 different ways
2. when trying on other systems, or in the same computer with another/blank 
disk - installation going fine.


I'll try 7.1 when it will be available wider.
Comment 5 Brent Fox 2001-04-24 14:39:49 EDT
Putting in 'Needinfo' state until then.
Comment 6 Need Real Name 2001-05-07 08:25:34 EDT
7.1 do fine
Comment 7 Brent Fox 2001-05-07 16:11:04 EDT
Excellent.  Thanks for working with us on this report.

Note You need to log in before you can comment on or make changes to this bug.