Bug 35868 - RFE: rpm should ingnore CR in spec files
RFE: rpm should ingnore CR in spec files
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 08:27 EDT by Dag Wieers
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2001-04-13 08:27:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-ac3 i686; Nav)


RPM doesn't handle SPEC-files in a DOS textfile format, although this could
be the expected behaviour, the error it returns is very obscure and
mind-boggling at first sight.

In a shell you get the following error (because of the non-ascii output):

+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ 
: command not found926: 
error: Bad exit status from /var/tmp/rpm-tmp.34926 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.34926 (%prep)


Reproducible: Always
Steps to Reproduce:
1. Simply convert your SPEC file to the DOS textfile format
2. (in vi: set ff=dos)
3.
	

Expected Results:  RPM should tell me it is in DOS textfile format, or it
should silently accept it and process it.
Comment 1 Bill Nottingham 2005-09-29 17:43:23 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.