Bug 358811 - Installation of WebSphere AS 6.0 and WebSphere Community Server 2.0 fails
Installation of WebSphere AS 6.0 and WebSphere Community Server 2.0 fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 14:36 EDT by Timo Hirt
Modified: 2008-04-25 23:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 23:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Hirt 2007-10-30 14:36:26 EDT
Description of problem:

I need Websphere Application Server V6.0 for work. If I try to start the
installer there are some swing errors and the install progress breaks. I tried
to install the AS with the same CD on Ubuntu 7.10 and it worked fine. I have no
idea why I have this errors with Fedora. I tried Sun SDK 5 and 6. The WebSphere
installer log says:

Install, com.installshield.wizard.StandardWizardListener, err, could not
initalize interface swing.


Version-Release number of selected component (if applicable):


How reproducible:

Restart the graphical installer and try to install the AS.

Steps to Reproduce:
1. Change dir to the install CD.
2. Type ./launchpad.sh as root or with sudo
3. Klick at "install WebSphere Application Server"
  
Actual results:

The installer tries to locate the JVM. Then the it breaks.

Expected results:

A working install of the Application Server.

Additional info:

I tried the shipped java version, sun java 1.4 and 1.6.
Comment 1 Thomas Fitzsimmons 2007-10-30 14:44:37 EDT
Please post the output of

sh -x ./launchpad.sh
Comment 2 Timo Hirt 2007-10-30 15:00:39 EDT
+ trap '' 22
+ whichBrowser=NoBrowser
+ case "$0" in
++ pwd
+ fullpath=/home/timo/Desktop/esb/./launchpad.sh
++ echo /home/timo/Desktop/esb/./launchpad.sh
++ sed 's,/\./,/,g; s,/[^/][^/]*/\.\./,/,g; s,//,/,g; s,/[^/]*$,,'
+ installsourcepath=/home/timo/Desktop/esb
+ '[' '' ']'
+ '[' NoBrowser = NoBrowser ']'
+
PATH=/usr/bin:/bin:/usr/X11R6/bin:/usr/local/bin:/usr/bin:/opt/mozilla:/usr/mozilla:/usr/mozilla/sfw/lib/mozilla
+ versionString=
+ '[' NoBrowser = NoBrowser ']'
+
PATH=/usr/bin:/bin:/usr/X11R6/bin:/usr/local/bin:/usr/bin:/opt/mozilla:/usr/mozilla:/usr/mozilla/sfw/lib/mozilla:/opt/firefox:/usr/firefox:/usr/firefox/sfw/lib/firefox
+ versionString='Mozilla Firefox 2.0.0.8, Copyright (c) 1998 - 2007 mozilla.org'
+ BROWSER=firefox
+ export BROWSER
+ supportedFirefoxVersion 'Mozilla Firefox 2.0.0.8, Copyright (c) 1998 - 2007
mozilla.org'
+ case "$*" in
+ return 0
+ whichBrowser=Firefox
+ '[' Firefox = NoBrowser ']'
+ '[' -z '' ']'
+ LaunchPadContentDir=content/
+ export LaunchPadContentDir
++ /home/timo/Desktop/esb/launchpad/SetArchitecture.sh
+ LaunchPadArch=x86
+ export LaunchPadArch
+ eval exec /home/timo/Desktop/esb/launchpad/Firefox.sh
++ exec /home/timo/Desktop/esb/launchpad/Firefox.sh
+ firefox -P Profile_3627 -profile /tmp/IBM_LaunchPad_3627/Profile_3627
file:///home/timo/Desktop/esb/launchpad/Mozilla.html
InstallShield Wizard

Initializing InstallShield Wizard...

Searching for Java(tm) Virtual Machine...
........The installer is unable to run in graphical mode. Try running the
installer with the -console or -silent flag.
Comment 3 Thomas Fitzsimmons 2007-10-30 15:28:37 EDT
I'll need more information about how the installer is searching for the JVM. 
Does launchpad.sh accept any options to enable verbosity?  Does the Mozilla.html
source provide any clues?
Comment 4 Timo Hirt 2007-10-31 13:28:42 EDT
I dont know about any options for launchpad.sh. Its a shell script which
determines the browser and runs another script. In my case its firefox.sh. 

Mozilla.html contains a lot of java script.
Comment 5 Thomas Fitzsimmons 2007-11-01 10:03:02 EDT
The checks must be happening in JavaScript.

First be sure that no other instance of Firefox is running on your system.  Then
replace the last line in /usr/bin/firefox with

exec strace -fFv -s300 $MOZ_PROGRAM $MOZARGS ${1+"$@"}

then run

sh -x ./launchpad.sh >& launchpad.log

then grep through the log for system calls "open", "access" and "stat64" to see
if it's searching through known Java installation paths.
Comment 6 Timo Hirt 2007-11-01 13:03:30 EDT
Ok, I did what you posted but without success. Lauchpad doesnt even open firefox
and prints out that no browser could be found. Even manually setting of the
BROWSER variable helped. 
Comment 7 Thomas Fitzsimmons 2007-11-02 10:44:50 EDT
What happens, with the modified /usr/bin/firefox, if you just run

/usr/bin/firefox http://slashdot.org

making sure that no other firefox instances are already running?
Comment 8 Thomas Fitzsimmons 2008-04-25 23:00:51 EDT
I checked these myself.

WebSphere Application Server V6.1 for Linux bundles its own JRE with which it
runs the installer.  This works fine on x86 Rawhide.

WebSphere Community Server 2.0's installer supports exclusively the following JVMs:

ibm-linux3264-15x.jvm
sun-linux32-15x.jvm
ibm-aix32-15x.jvm
sun-solaris32-15x.jvm
apple_macosx_15X.jvm

and does not provide the ability to run a JVM not in that list.

Closing CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.