Bug 35897 - Wolverine Xfree86 server reboots itself intermittantly
Wolverine Xfree86 server reboots itself intermittantly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 35818 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 14:25 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 10:31:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages (352.29 KB, text/plain)
2001-04-13 14:26 EDT, Need Real Name
no flags Details
Xfree86.0.log (24.31 KB, text/plain)
2001-04-13 14:28 EDT, Need Real Name
no flags Details
XF86Config (16.06 KB, text/plain)
2001-04-13 14:29 EDT, Need Real Name
no flags Details
cpuinfo (744 bytes, text/plain)
2001-04-13 14:34 EDT, Need Real Name
no flags Details
devices (255 bytes, text/plain)
2001-04-13 14:35 EDT, Need Real Name
no flags Details
interrupts (630 bytes, text/plain)
2001-04-13 14:36 EDT, Need Real Name
no flags Details
modules (1.06 KB, text/plain)
2001-04-13 14:37 EDT, Need Real Name
no flags Details
tail on my current messages file showing kernel:APIC errors (560 bytes, text/plain)
2001-04-13 14:42 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-04-13 14:25:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9smp i686)


Running Xfree86 on Wolverine, and Xserver reboots on occasion,
unexpectedly.
Running Netscape Communicator and Messenger and maybe an xterm at the time.
I noted the X reboot seems to affect stability of Messenger, Realplayer,
which I 
reinstalled to make them work again. Video card is an ATI Expert @ Play 98.

Reproducible: Sometimes
Steps to Reproduce:
1. Wolverine w/Xfree86
2.  smp kernel 2.4.1 on dual celeron500
3.  X reboots back to X login prompt & all X apps get killed.
	

Actual Results:  This is intermittant, I don't know if it is "reproducable"
except intermittantly.  I did notice some 

Expected Results:  X ought to be stable.

See former bug #35818 which is the same thing, but I couldn't upload the
logs/config files requested due to the link timing out. I will try to
upload them with this new bug report.  If I run into issue uploading via
the link, I hope you (Redhat) can give me an alternative way to get you my
files. I've also noted "APIC error"  on "CPU0" and "CPU1" in my messages.
Comment 1 Need Real Name 2001-04-13 14:26:59 EDT
Created attachment 15325 [details]
messages
Comment 2 Need Real Name 2001-04-13 14:28:26 EDT
Created attachment 15326 [details]
Xfree86.0.log
Comment 3 Need Real Name 2001-04-13 14:29:08 EDT
Created attachment 15327 [details]
XF86Config
Comment 4 Need Real Name 2001-04-13 14:34:50 EDT
Created attachment 15328 [details]
cpuinfo
Comment 5 Need Real Name 2001-04-13 14:35:29 EDT
Created attachment 15329 [details]
devices
Comment 6 Need Real Name 2001-04-13 14:36:54 EDT
Created attachment 15330 [details]
interrupts
Comment 7 Need Real Name 2001-04-13 14:37:42 EDT
Created attachment 15331 [details]
modules
Comment 8 Need Real Name 2001-04-13 14:42:53 EDT
Created attachment 15332 [details]
tail on my current messages file showing kernel:APIC errors
Comment 9 Mike A. Harris 2001-04-13 16:00:34 EDT
Thanks very much for resubmitting this bug report properly!  I'll
look into it and see what i can come up with.
Comment 10 Mike A. Harris 2001-04-13 16:09:44 EDT
*** Bug 35818 has been marked as a duplicate of this bug. ***
Comment 11 Need Real Name 2001-04-16 08:00:28 EDT
35818 was only my 1st attempt to post this bug - it is not a fix for 35897. 
35897 contains logs and config files that apply to 35897 (and original 35818).
Comment 12 Mike A. Harris 2001-04-16 10:31:08 EDT
Nothing is claiming the bug is fixed.  Bug #35818 and this one are
identical bug reports.  This one obsoletes the previous one which was
some 400k+ of inline text, making the bug difficult to view as it was
not submitted properly.

Since you've resubmitted the bug as I asked, the old bug is a duplicate
and no longer needed.  Please be patient, and I will update this report
when the status of the bug changes.  Until then there is not much that
can be done.

Comment 13 Mike A. Harris 2001-04-16 10:42:30 EDT
I've looked at the details of your provided files.  You are using VMware,
which is an unsupported configuration.  VMware contains kernel modules
(vmmon, vmnet) which can cause all sorts of random lockups, etc. like
you are experiencing.  The APIC errors may or may not be related to this,
however they are kernel errors, not XFree86 errors.

I am closing this bug due to the unsupported configuration with VMware.
Disable VMware entirely, including vmware's kernel modules from loading
at boot time, install the latest rawhide kernel and latest XFree86 RPM
packages, reboot without vmware and see if your trouble goes away.  I'm
betting VMware is causing the crashes, as I have seen it do so in the
past.  If you still experience these X server deaths without vmware,
reopen the bug report, and attach a server log from a crash.  This means
when X crashes, you need to get the log without starting up X, or the new
X session will overwrite the crash log report.  I recommend booting
runlevel 3 and running X with "startx" until it crashes, get the log,
attach it to bugzilla, and we might find something more telling.
Comment 14 Mike A. Harris 2001-04-16 10:46:34 EDT
Oh, I forgot o mention, if you continue to experience APIC errors using
the latest kernel, without vmware, then open a bug report on the "kernel"
component.

Thanks.
Comment 15 Need Real Name 2001-04-16 17:30:32 EDT
Please specify what the newest Wolverine kernel should be.  I have
2.4.1-0.1.9smp.  Are there updated 2.4.x RPM-based kernels I can install from
Redhat, for Wolverine - where to download?  
I've not installed Rawhide kernels before. Where are latest Xfree86 Wolverine
RPM packages??? I have not seen RPM updates, per say, for Wolverine.

I will remove vmware, upgr kernel and X,  see if it stabalized things, do
runlevel 3 if crashes continue, and if APIC errors continue with new kernel post
a kernel bug........ many thanks.


Comment 16 Mike A. Harris 2001-04-16 17:57:27 EDT
As of today, Red Hat Linux 7.1 (Seawolf) was officially released.
Wolverine (the beta) is no longer relevant.  You can obtain the new
distribution by free download from ftp://ftp.redhat.com/pub/redhat/linux
Alternatively you can purchase it online in a few days or so from our
website if you desire:  http://www.redhat.com

Upgrades to or from beta releases are not guaranteed to work so it is
recommended that you do a fresh install.  However, if you wish, you can
try an upgrade, however you may experience problems.  You may also wish
to join our mailing list for Seawolf by sending a message with "subscribe"
in the subject to:  seawolf-list-request@redhat.com

See you on the list!  Hope you enjoy Seawolf!

Note You need to log in before you can comment on or make changes to this bug.