Bug 359 - Frequent random crashes of X server (on SPARC)
Frequent random crashes of X server (on SPARC)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
5.2
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
: 632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-08 21:39 EST by William Shotts
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-19 11:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shotts 1998-12-08 21:39:41 EST
On sun4C machines (I'm using a SS1+) there are frequent
random crashes of the X server.  This has been discussed on
the mailing list.  Happens regardless of window manager
used.  System often hangs console and must be rebooted from
remote system.
Comment 1 Jeff Johnson 1998-12-09 12:50:59 EST
I suspect that this problem has to do with the version of glibc
that you are running. You can identify the version by doing
	rpm -q glibc
and if the answer is "glibc-2.0.7-19" or earlier you should upgrade to
either glibc-2.0.7-29 (Red Hat 5.2) or later (from update errata).

The problem is sparc and sparc only and has to do with the
pagesize used to align mmap requests.

Please reopen this bug report if my guess is incorrect.
Comment 2 Jeff Johnson 1998-12-09 12:51:59 EST
I suspect that this problem has to do with the version of glibc
that you are running. You can identify the version by doing
	rpm -q glibc
and if the answer is "glibc-2.0.7-19" or earlier you should upgrade to
either glibc-2.0.7-29 (Red Hat 5.2) or later (from update errata).

The problem is sparc and sparc only and has to do with the
pagesize used to align mmap requests.

Please reopen this bug report if my guess is incorrect.
Comment 3 William Shotts 1998-12-09 13:55:59 EST
I am using RedHat 5.2 which supplies glibc-2.0.7-29.  With a plain
5.2 I sometimes get the "Bezier too large" messages that were
reported in another bug.  Using the 2.1.129 kernel the crashing
problem becomes much worse.  I will only run for a few minutes before
it dies.
Comment 4 David Lawrence 1998-12-29 15:38:59 EST
Derek has stated that he has been able top observe this happening. I
am assigning it to a developer for further review.
Comment 5 Preston Brown 1999-01-11 14:05:59 EST
*** Bug 359 has been marked as a duplicate of this bug. ***

The Sun 8 bit Xserver crashed 3 times in two days while
playing solitaire (pysol).  It did not leave a core dump,
nor messages in any log.  I have been unable toreproduce it
since.  XFree86 version 3.3.3.

------- Additional Comments From dlt@redhat.com  12/29/98 11:50 -------
It happened again this morning.  kbd-mode -a restores function so that
one switch to another vc and start x again.  It still is difficult
to reproduce.

------- Additional Comments From dkl@redhat.com  12/31/98 15:30 -------
This bug has been assigned to a developer for further review.
Comment 6 Preston Brown 1999-02-19 11:18:59 EST
The most recent rawhide X release (XFree86-3.3.3.1-19) contains a
number of patches to the sun framebuffer devices.  Please try it, and
reopen the bug if you are still having problems. You may have to
rebuild the package if you are still running glibc 2.0, as it is
linked against glibc 2.1.  Alternatively, wait for 6.0.

Note You need to log in before you can comment on or make changes to this bug.