Bug 35915 - Wolverine Samba and Windows Me networking crash both.
Wolverine Samba and Windows Me networking crash both.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 17:50 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 17:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.conf (4.15 KB, text/plain)
2001-04-13 17:52 EDT, Need Real Name
no flags Details
samba.tar log files (use tar xvf samba.tar to untar to /var/log/samba) (70.00 KB, application/octet-stream)
2001-04-13 17:55 EDT, Need Real Name
no flags Details
smb.log (one of the files in samba.tar - logs dated Aug 13 most current samba usage) (528 bytes, text/plain)
2001-04-13 18:02 EDT, Need Real Name
no flags Details
smb.log (goes along with win95 fatal error comment) (1.03 KB, text/plain)
2001-04-13 18:56 EDT, Need Real Name
no flags Details
win95workstation.log (samba log of the win95 pc that got fatal error when trying to copy file from it to wolverine) (11.16 KB, text/plain)
2001-04-13 18:58 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-04-13 17:50:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9smp i686)


When enabling Samba-2.0.7-31 on Wolverine and mounting a drive to a Windows
Me computer, one of two things happen, if not both. 

Reproducible: Always
Steps to Reproduce:
1. /etc/rc.d/init.d/smb start; mount -t smb //windowsmehost/c /mnt/winme/c
2. df (shows mounted)
3. attempt to copy a file from/to  Windows Me / Wolverine
4. either one or both computers lock up solid, or
the contents of /mnt/winme/c drive can no longer be seen,
or you may not even see the ./c directory on Wolverine file system!
(Though if you mounted a c and d, the c might disappear, and d still
there.)
5. If issue (4) is seen, then you cannot dismount ./c   
6. Meanwhile a Windows 95 computer networked with Wolverine
appears not to have this issue.

	

Actual Results:  Attempting to access file system from Wolverine to Windows
Me such as file copy, and Wolverine locks and/or Windows Me locks up too.

Expected Results:  Should be able to copy files between, etc. no problem.

See attached samba.conf and samba log.
Comment 1 Need Real Name 2001-04-13 17:52:01 EDT
Created attachment 15344 [details]
smb.conf
Comment 2 Need Real Name 2001-04-13 17:55:25 EDT
Created attachment 15345 [details]
samba.tar log files (use tar xvf samba.tar  to untar to /var/log/samba)
Comment 3 Need Real Name 2001-04-13 18:02:52 EDT
Created attachment 15346 [details]
smb.log (one of the files in samba.tar - logs dated Aug 13 most current samba usage)
Comment 4 Need Real Name 2001-04-13 18:53:55 EDT
It also appears that long as the Windows Me is up and running, it also affects
the stability of the Windows 95 and Redhat Wolverine smb networking. (I will
have to test this by shutting down Me)  Tried to copy a file from Windows 95 to
Wolverine, and Win95 got a blue screen "fatal error", but came back when press
any key.  Wolverine could not receive a file from it.  I'll include update samba
logs following this update. (Note: previous to wolverine I ran RHLinux 6.2
k2.2.16 and Win95 and Linux/samba network was just fine. Win Me was newly
introduced as was Wolverine. Three seperate computers, 95, Me, Wolv.) 

Comment 5 Need Real Name 2001-04-13 18:56:50 EDT
Created attachment 15348 [details]
smb.log (goes along with win95 fatal error comment)
Comment 6 Need Real Name 2001-04-13 18:58:18 EDT
Created attachment 15349 [details]
win95workstation.log (samba log of the win95 pc that got fatal error when trying to copy file from it to wolverine)
Comment 7 Need Real Name 2001-04-16 08:02:02 EDT
Is anyone at Redhat looking into this bug yet, I have not heard from any of you.
Please advise.
Comment 8 Bill Nottingham 2001-04-16 10:39:00 EDT
You might try asking on the samba mailing lists as well.

The log files do not really show anything; when *exactly* was the failed copy
(there aren't any error messages in the samba logs that show errors.)
Comment 9 Need Real Name 2001-04-16 17:07:09 EDT
The copy you ask about was a simple gzip file I was attempting to cp from the
windows me box to my wolverine box. The result is a 0 byte file on wolverine,
and one or both systems lock up. But does not matter what I am trying to copy
tiny or large, ascii or binary.  Same result.   What about the file handle
complaint in smb.log like so:  
[2001/04/13 18:43:17, 1] smbd/files.c:file_init(215) file_init: Information
only: requested 10000 open files, 1014 are available.  
And how about the myshare and  invalid user authorization entries in the
win95workstation.log file?
There is really something wacky about win me and samba on wolverine. 

Comment 10 Bill Nottingham 2001-04-16 17:20:33 EDT
The file handle thing is not an error. The 'myshare' error implies that
it's looking for a 'myshare' share that isnt in your smb.conf (it's not in
the one posted.)

Without a timestamp of *when* you tried to copy the file, I can't correlate
the other errors to the problem you're seeing.
Comment 11 Need Real Name 2001-05-07 17:34:59 EDT
Hi, I'm no longer using Wolverine, I'm using Seawolf, so you can close this.  If
I continue with issues, I can reopen a new bugzilla.
Comment 12 Helge Deller 2001-05-08 04:47:13 EDT
closed on Peter's request...
Peter - if you still encounter the same problems with seawolf/7.1, could you 
please refer again to this bug ?

Comment 13 Need Real Name 2001-05-08 11:46:14 EDT
Yes, will do, if Seawolf (7.1) + Samba does the same as Wolverine (7.0.91), I
shall open a new bug, and refer to 35915.
Comment 14 Need Real Name 2001-05-28 16:39:55 EDT
 I no longer use Wolverine, and I've upgraded to the latest Samba....   I've
since upgraded to Redhat Linux 7.1 with kernel 2.4.2-2 and the Samba that comes
with it. Due to other issues, I further upgraded the Redhat rawhide
kernel to 2.4.3-7 and errata update for Samba 2.0.8-1.7.1.   This newer version
of
Samba appears to have stabilized my Linux Samba interaction with Windows Me
and Windows 95 on the same network. Thus far, no more Windows blue-screens
or freezed. So far, no weirdness to the "//windowspc/c /mnt/windows/c" file
system
mounted on my Linux computer, such as suddenly don't see the files in c,
or c itself diappearing, and can't dismount.  So far so good. HOWEVER, while
Linux can access Me and 95 ok, and 95 can access Linux ok, there seems to be an
issue
with Me accessing the Linux Samba shares - does not accept the passwords
(even though Me sees the Linux shared file system in Network Neighborhood).

The following solution fixes the Samba/Linux and Windows ME running with Windows
95:

Normally you could use "encrypt passwords = Yes" in your smb.conf file if
all your windows-machines are >= Win98 Second Edition. But you use Win95 and
ME parallel, so you need a different approach. You will need to set your ME
machine to use un-encrypted passwords and you should be done.
Search in the documentation for "plain passwords" in /usr/share/doc/samba*

For ME this should work: Copy the following between the "XXXX" into a file
called MEplaintext.reg (the extension is important!) and then double-click
(start) it from the windows-explorer. After a reboot of your win-machine
you should add the username to your samba-server and you should be done.

xxxxxxxxxxxxxxxxxxx save as "MEplaintext.reg" !!!
REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP]
"EnablePlainTextPassword"=dword:00000001
xxxxxxxxxxxxxxxxxxxx


Note You need to log in before you can comment on or make changes to this bug.