Bug 35916 - rhn_register Fatal error: No route to host; proxy issue?
rhn_register Fatal error: No route to host; proxy issue?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 17:55 EDT by Forrest
Modified: 2015-01-07 18:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 16:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Forrest 2001-04-13 17:55:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22.mvfs-7.0-test4 i686)


I just installed RH 7.0, and I wanted to run up2date behind my firewall.  I
got the new rpm-* and popt packages, as well as the rhn_*, up2date-* and
python-xmlrpc.  I first tried running up2date, but it says that I need to
run rhn_register first.  I run rhn_register, and it says:
Fatal error retrieving welcome message: No route to host

I thought that I should need to add in the proxy settings, so I ran
up2date-config, and add in the proxy setting.  Rhn_register gives the same
error.

Reproducible: Always
Steps to Reproduce:
1.  Run rhn_register behind firewall
2.
3.
Comment 1 Forrest 2001-04-13 18:01:54 EDT
I just got some more info running it from the console with debug on:
shell-init: could not get current directory: getcwd: cannot access parent
directories: No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access
parent directories: No such file or directory

I am also using NIS, but su - to root.  I've also tried just logging in as root,
with the same results.
Comment 2 Jay Turner 2001-04-16 07:53:16 EDT
Those messages about not being able to get current directory sound like you are
operating in an nfs-mounted directory which is no longer mounted (i.e. the
directories went away and are no longer valid.)

As for the proxy stuff not working, send me you /etc/sysconfig/rhn/up2date file
and I will take a look.  Might be that we are parsing the proxy settings that
you have incorrectly.
Comment 3 Forrest 2001-04-17 13:52:51 EDT
You are correct, I am using autofs, and the NFS mounts had just expired.  I am
sending you my up2date file now.  Notice that I have three dots in the name
(e.g. proxy.myproxy.mydomain.com) and a port number under 1000.
Comment 4 Forrest 2001-04-17 14:29:41 EDT
I just ran rhn_check (although I'm not sure what it is supposed to do), and I
get an error:
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 22, in ?
    from translate import _, N_, cat
ImportError: No module named translate

lines 22-24 read:
from translate import _, N_, cat

sys.path.append("/usr/share/rhn/up2date")

Is this any help?
Comment 5 Forrest 2001-04-17 14:32:35 EDT
I just ran rhn_check, and I get this error:
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 22, in ?
    from translate import _, N_, cat
ImportError: No module named translate


Lines 22-26 read:
from translate import _, N_, cat

sys.path.append("/usr/share/rhn/up2date")

import up2date

Does this help?
Comment 6 Jay Turner 2001-04-17 15:05:43 EDT
That missing module thing means that you need to upgrade to the latest version
of python-xmlrpc.  In addition, check 'rhn_register --config' and make sure that
the proxy settings are correct there.
Comment 7 Forrest 2001-04-17 16:17:10 EDT
I belive that I got the latest python-xmlrpc when I upgraded up2date and rpm:
python-xmlrpc-1.4-1
rpm-4.0.2-7x
up2date-2.5.3-1

I tried rhn_register --config, but it gives exactly the same error.
Comment 8 Jay Turner 2001-04-17 16:23:54 EDT
Check your /usr/share/rhn/up2date directory and confirm that there is a
translate.py file in there.
Comment 9 Forrest 2001-04-17 16:31:53 EDT
Yes, translate.py is there.
Comment 10 Jay Turner 2001-04-17 16:43:50 EDT
OK, I am an idiot.  There is indeed a bug which relates to the attempt to import
translate before appending to the sys.path.  We are fixing it up right now.
Comment 11 Forrest 2001-04-19 14:52:18 EDT
I found the new up2date packages on an update site, so I installed them.  Now,
running rhn_check, I get:

ERROR: unable to read system id.

Running rhn_register --config just hangs.  After about 15 minutes it comes back
with the error:
Fatal error retrieving welcome message: Connection timed out

Also, is anyone working on a man page for rhn_*?  I didn't even know about
rhn_register --config.
Comment 12 Hugh Bragg 2001-04-20 07:27:58 EDT
I have a similar problem.
I'm working behind a firewall and we use a proxy to resolve host addresses.
I can't resolve external hostnames except using netscape with proxy enabled.
Is there anyway I can use up2date too?
Comment 13 Forrest 2001-04-20 13:38:38 EDT
It seems as though rhn_register --config does not do what it was intended to. 
rhn_register --config brings up exactly the same thing as rhn_register with no
flags.  In fact, I type anything I want after rhn_register -- and I get the same
thing.
This is opposed to up2date where if I type up2date --configure, --conf, or even
--c I get the configuration options.
Comment 14 Hugh Bragg 2001-05-22 04:55:22 EDT
Whenever I run rhn_register either in X or not, I get  the same message:
Fatal error retrieving welcome message: host not found.
I can only access internal dns except through the proxy. The proxy does all the
resolving but
rhn_register tries to use the internal dns to find the host name.
I cannot use nslookup with the proxy as a server since it only answers http,
https and ftp requests.
There must be some way rhn_register can be forced to use the proxy as the name
server.
There is no authentication on the proxy, it just accepts requests and returns
the data seemlesly.
Comment 15 Hugh Bragg 2001-05-22 04:59:14 EDT
I find this problem and I am using Redhat 6.2
rhn_register-1.3.2-0.6.x and up2date-2.5.4-0.6.x
Comment 16 Hugh Bragg 2001-06-08 07:00:32 EDT
I can and am using the up2date once if figured it out.
I could not get rhn_register to work with proxy address proxy:8080
I had to use http://proxy.8080 in rhn_register and proxy:8080 in up2date.
There is no information on this and it should be fixed.
Comment 17 Forrest 2001-06-12 15:21:21 EDT
How did you get rhn_register to configure the proxy?  Did you use rhn_register -
-config?  Are you using Redhat 7.1?
Comment 18 Hugh Bragg 2001-06-19 02:22:28 EDT
I use RH 6.2. I configured rhn_register using vi on
/etc/sysconfig/rhn/rhn_register , but you should be able to use rhn_register
-configure (which is what I tried first) as long as the proxy address has
http://<hostname>:<port> in that file and just simply <hostname>:<port> in
/etc/sysconfig/rhn/up2date

Note You need to log in before you can comment on or make changes to this bug.