Bug 35920 - rhn_register dump core
Summary: rhn_register dump core
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-14 06:21 UTC by John Newbigin
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 21:37:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script output of crash (3.98 KB, text/plain)
2001-04-17 01:23 UTC, John Newbigin
no flags Details

Description John Newbigin 2001-04-14 06:21:03 UTC
when running rhn_register on a 386, the screen is filled with the blue background and then I get a Segmentation fault (core dumped)

[root@gw /root]# file core
core: ELF 32-bit LSB core file of 'rhn_register' (signal 11), Intel 80386, version 1

I assume that it is python which is crashing but I don't know anything about python.

I have the following RPM's installed
python-xmlrpc-1.4-0.6.x
rpm-python-4.0.2-6x
python-1.5.2-27.6.x


I have upgraded to rhn_register-1.3.2-0.6.x and the problem still persists.

Comment 1 Preston Brown 2001-04-16 15:09:10 UTC
Jay:

can you verify?

JN:  Do you get the segfault right away, or does it go through a couple of 
screens first and then segfault?


Comment 2 Jay Turner 2001-04-16 19:02:19 UTC
Not in our lab.  Oldest thing that we have is a 486SX.

Comment 3 John Newbigin 2001-04-17 01:23:04 UTC
Created attachment 15464 [details]
script output of crash

Comment 4 John Newbigin 2001-04-17 01:27:08 UTC
When rhn_register is started, there is about 20 seconds of disk grindage (it is
a 386 after all, 7.94 bogomips).  Then the screen colors are set to white on
blue, the screen is cleared and then the crash.  I have attached a typescript
which probably won't help much.

One thing it could be is the CPU does have the popad bug but I would imagine
that the compiler would not use that instruction if it was known to be buggy
(not to mention extreemly inefficient)

Comment 5 Adrian Likins 2001-07-06 00:30:34 UTC
If this still happens with the latest versions, could you attach a copy
of the core dump?

I really havent a clue what is causing this atm, but suspect it is
a bug somewhere either deep in python, or perhaps rpm.

Have you had any similar crashes with rpm on this machine? How about any
other python or gtk apps?

Comment 6 John Newbigin 2001-07-06 01:55:50 UTC
I have had problems on the machine before with RH6.0 because something (glibc?) was compiled with i486 instructions.  This however caues 'illegal instruction' 
errors. SIGILL.

I have now upgraded the box so I can not test it immediatly but I still have the machine if you want to persue this.

I did not have any problems with RPM.
The only python app I ran was rhn_register.

Is there a pyhthon test suite?


Note You need to log in before you can comment on or make changes to this bug.