Bug 359261 - Multile nsviewfilter's in multi-master replication can crash server if deleted.
Summary: Multile nsviewfilter's in multi-master replication can crash server if deleted.
Status: CLOSED DUPLICATE of bug 288291
Alias: None
Product: 389
Classification: Retired
Component: Personalized Views   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-30 21:37 UTC by Brian Junker
Modified: 2015-01-04 23:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 15:19:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Junker 2007-10-30 21:37:21 UTC
If you have the following setup in a multi-master replication:

dc=acme,dc=test
|
|
+--Clovis
   |
   |
   +--Finance

ou=Clovis,dc=acme,dc=test
	objectClass: nsview
	nsviewfilter: (l=Clovis)

ou=Finance,ou=Clovis,dc=acme,dc=test
	objectClass: nsview
	nsviewfilter: (departmentNumber=finance)

If you delete the Finance OU under the Clovis OU, the server will crash.

Comment 1 Rich Megginson 2007-10-30 21:47:28 UTC
Does it crash if you don't use multi-master?

Comment 2 Brian Junker 2007-10-30 22:39:58 UTC
No, it does not.  Only when you have multi-master.

Comment 3 Rich Megginson 2007-10-31 15:19:58 UTC
I think this has been fixed as part of
https://bugzilla.redhat.com/show_bug.cgi?id=288291 which was also a crash
related to view filters.  This what I did:
* create two masters m1 and m2
* init m1 from Example.ldif
* create repl agreements and init m2 from m1
* verify that repl is working
* add ou=Clovis to m1 - verify that it gets replicated to m2
* add ou=Finance to  m1 - verify that it gets replicated to m2
* delete ou=Finance - verify that it gets replicated to m2

These steps on Fedora DS 7.1 crash m1.  This all works fine on Fedora DS 1.1
(current CVS HEAD code).

*** This bug has been marked as a duplicate of 288291 ***


Note You need to log in before you can comment on or make changes to this bug.