Bug 35934 - startkde assumes desktop is ${HOME}/Desktop
startkde assumes desktop is ${HOME}/Desktop
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.0
All Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-14 10:46 EDT by Benjamin S. Scarlet
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-14 10:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin S. Scarlet 2001-04-14 10:46:04 EDT
KDE is now capable of letting the user choose the directory to
represent the desktop.  The RedHat modified version of startkde, however,
still copies Desktop from the skeleton directory whenever ${HOME}/Desktop
is not present, using the default name.  Thus if one changes the desktop
directory in the control center and then logs in again, an erroneous 
second desktop directory with the old name is always forced into 
existence.
Comment 1 Bernhard Rosenkraenzer 2001-04-15 16:19:24 EDT
Don't do that then(tm).
We need to "mess with" the Desktop files for translations and stuff to work 
properly.

Reading them out using kreadconfig won't work because kreadconfig depends on a 
running instance of kded, and we're generating the desktop directories earlier 
than that.

Using grep, awk and friends to parse the config files would be too much 
overhead.

The best workaround for the problem I can think of right now is to copy the 
desktop files unless ~/.kde/share/config/kdesktoprc already exists (this file 
contains the setting for the correct desktop directory), but that would mess 
up people who ran rm -rf * in their home directory...

Anyway, this is a minor problem; I'll check if I can find a good fix the next 
time I update the packages.

Note You need to log in before you can comment on or make changes to this bug.