Bug 35935 - bash not processing /etc/profile with gnome
Summary: bash not processing /etc/profile with gnome
Status: CLOSED DUPLICATE of bug 32408
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-14 17:17 UTC by Merten Gustafson
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-19 21:20:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Merten Gustafson 2001-04-14 17:17:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001108
Netscape6/6.0


Logging on as root to linux box using XDM. Starting a gnome terminal.
Preferences stored in /etc/profile are not available, i.e. /etc/profile is
not executed.

Reproducible: Always
Steps to Reproduce:
1. login as root using XDMCP
2. start gnome terminal
3. echo $MAIL
4. bash --login
5. echo $MAIL
/var/spool/mail/root

	

Actual Results:  echo $MAIL didn4t print anything until after bash --login

Expected Results:  echo $MAIL should result in output after starting shell

This used to work in pre 7.0 installations

Comment 1 Bernhard Rosenkraenzer 2001-04-15 19:48:43 UTC
If this is a problem, it's a gnome-terminal problem and not a bash problem.

I don't think it's a problem though, since all konsole, xterm, rxvt and 
gnome-terminal agree that the shell should not be launched as a login shell.



Comment 2 Merten Gustafson 2001-04-17 18:25:48 UTC
When logging on to the box using XDM and starting gnome, should4t there be a
first shell executed as login? When logging on to a console the /etc/profile is
executed, I can4t see why logging on using x-windows should be different.



Comment 3 Havoc Pennington 2001-04-18 22:46:58 UTC
gnome-terminal has a prefs option to run a login shell or not. If you're worried
about X as a whole, that's the Xsession script in the xinitrc package.

Comment 4 Merten Gustafson 2001-04-19 21:52:43 UTC
Where is that prefs option?

Comment 5 Havoc Pennington 2001-04-19 22:34:38 UTC
On the first notebook tab, "use --login by default"

Comment 6 Alex Kanavin 2001-04-30 10:20:32 UTC
This is the duplicate of the bug #32408, please see it for the accurate problem
description and a proposed fix which I fully support!

Comment 7 Alan Cox 2001-05-19 20:29:11 UTC
Agreed. Once I realised it was not about the shell login properties but about X
clients being started with the right options it makes complete sense


Comment 8 Merten Gustafson 2001-05-19 21:20:52 UTC
I have read the bug description #32408. The fix I believe is in the original bug
report I believe. However, I would preffer if a RedHat support person confirmed
the resolution.

Besides, the -On the first notebook tab, "use --login by default"- entry didnt
give me much help.


Comment 9 Havoc Pennington 2001-05-19 22:34:16 UTC
Not sure how this will get resolved, but we may as well have only one copy of
the bug, so marking this one duplicate.

*** This bug has been marked as a duplicate of 32408 ***


Note You need to log in before you can comment on or make changes to this bug.