Bug 35938 - up2date -l returns
Summary: up2date -l returns
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-14 21:27 UTC by Joe Klemmer
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-14 21:28:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Klemmer 2001-04-14 21:27:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)


The -l option stopped working when I upgraded to up2date v2.5.2 .  
The exact error message looks like this:

# up2date -l
There was a fatal RPM error.  The message was:
Couldn't determine what version of Red Hat Linux you are running.

Reproducible: Always
Steps to Reproduce:
1. su -
2. up2date -l
3. "Error occurs"
	

Actual Results:  # up2date -l
There was a fatal RPM error.  The message was:
Couldn't determine what version of Red Hat Linux you are running.

Expected Results:  # up2date -l

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
100.0%

Comment 1 Jay Turner 2001-04-16 11:47:50 UTC
The change from rpm-3.0.x to rpm-4.0.2 requires that the rpm database be
rebuilt.  This is why you are getting this error.  So, as root, run the
following:  'rpm --rebuilddb'

Once that has completed, you should be able to run up2date again without problems.


Note You need to log in before you can comment on or make changes to this bug.