Bug 35966 - wrong video geometry for Dell Inspiron 7500
wrong video geometry for Dell Inspiron 7500
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-15 13:59 EDT by Marty Shannon
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 17:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marty Shannon 2001-04-15 13:59:23 EDT
This is in SEAWOLF!

During CD/GUI/fb install, configuring X on a Dell Inspiron 7500: For all of
the ATI Mobility video cards, 1280x1024 does *not* show up as an acceptable
resolution, though 1400x1050 does (incorrectly).  Dell ships (shipped? it
isn't even a year old yet!) this laptop with a choice of 2 displays.  One
does 1400x1050 (and may be able to do 1280x1024), but the one I chose does
1280x1024 (and can't do 1400x1050).  According to the install screens, the
display is "DCC probed".  Somehow, there must be a way to differentiate
between these 2 displays.

BTW, I chose the display based on the fact that I should be able to throw a
nice big monitor on it; with 1400x1050, I didn't think that would fly very
well (if at all).

We did go through this on an earlier beta, but I was unable to schedule
more testing in between.  Sorry, "real" work interfered.  I still don't
know if Xconfigurator is the correct component for install-time X
configuration.  If not, please adjust as necessary.
Comment 1 Brent Fox 2001-04-15 14:44:50 EDT
I'm not sure if Xconfigurator is involved here, but I know for sure that the
installer is not giving the choice of 1280x1024 with the ATI Rage Mobility
chipset.  The text based installer uses Xconfigurator, but the GUI does not.
What is the behavior like with the text installer?

Changing component to anaconda.
Comment 2 Marty Shannon 2001-04-15 15:22:25 EDT
Running Xconfigurator manually (after the GUI install) correctly allows me to
choose the Dell 1280X LCD.  Should I trust that Xconfigurator invoked through
the text installer will behave the same?
Comment 3 Brent Fox 2001-04-15 18:09:25 EDT
Yes.  I think the problem is specific to the GUI installer.  Will address in a
future release.
Comment 4 Brent Fox 2001-04-16 17:56:05 EDT
Fixed in cvs.  Should appear in post anaconda-7.1-5.i386.rpm builds.  Thanks for
your report.

Note You need to log in before you can comment on or make changes to this bug.