Bug 359951 - Brightness/Volume control doesn't work on T61
Summary: Brightness/Volume control doesn't work on T61
Status: CLOSED DUPLICATE of bug 363261
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session   
(Show other bugs)
Version: 9
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-31 11:13 UTC by Zdenek Kabelac
Modified: 2013-03-06 03:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 04:17:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zdenek Kabelac 2007-10-31 11:13:59 UTC
Description of problem:

Brightness setting doesn't work at all on my T61
While I have no problem to use  echo level 0-7 >/proc/acpi/ibm/brightness
setting via keyboard Fn usually leads to unpredictable behavior.

Also the buttons for sound volume/mute doens't work properly - mute does
something - but up/down volume does not.

Version-Release number of selected component (if applicable):
Power Manager Brightness Applet 2.20.0


How reproducible:

Running on Levovo T61 - whenver I use Fn+Home/End (up/down brightness)
I could see the brightness picture window which changes the brightness
value in its bar - but no actual brightness change could be visible.
Then sometime suddenly after something like 5 minutes the brightness
get changed somehow.

Also the brightness applet 2.20.0 does slightly better job - moving it
really cause to change the brightness - but this applet seems to be
unable to properly detect current level of brightness.

Steps to Reproduce:
1. Use Lenovo T61 and latest Fedora Devel
2. Try to use Fn keys for brightness / sound
3.
  
Actual results:
Randomly modified brightness and sound level 

Expected results:
Properly modified brightness and sound level

Additional info:

Comment 1 Feng Yu 2008-03-11 20:04:56 UTC
It still doesn't work in F8 
hal-info-20071030-1.fc8
gnome-power-manager-2.20.0-6.fc8


Comment 2 Feng Yu 2008-03-11 20:47:32 UTC
It shall be related to kernel in kernel 

kernel-2.6.23.1-42.fc8

it works (not fine: the brightness keys works, the volume keys are broken)

in
kernel-2.6.24.3-12.fc8
it stops working.


Comment 3 Feng Yu 2008-03-11 21:44:52 UTC
It is the kernel module video causes this.

by blacklisting 'video' and forcing 'thinkpad-acpi' to control the brightness,
the brightness setting in gnome-powermanager works, but the thinkpad Fn-keys for
brightness stops working.

the volume controlling issue is caused by gnome-powermanager tries to modify the
volume of my external soundcard. By disabling the keys in System->Shortcuts it
becomes fine.












Comment 4 Feng Yu 2008-03-11 21:51:32 UTC
No the volume fix should be in /etc/modprobe.conf

alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-usb-audio

options snd cards_limit=3

options snd-card-0 index=0
options snd-hda-intel index=0 power_save=5

options snd-usb-audio index=1
options snd-card=1 index=1

options thinkpad-acpi brightness_enable=1 hotkey_report_mode=2



Comment 5 Feng Yu 2008-03-13 07:58:16 UTC
no gnome-power-manager still randomly controls either the build-in soundcard or
the external sound card.


Comment 6 Richard Hughes 2008-04-30 09:10:44 UTC
gnome-power-manager doesn't do anything with the volume keys.

Comment 7 Richard Hughes 2008-04-30 09:44:40 UTC
Taking a guess at the component.

Comment 8 Bug Zapper 2008-05-14 03:48:36 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Zdenek Kabelac 2008-06-06 08:42:33 UTC
This bug could be closed - it loosk like recent version these applets operates
properly (except for the weird behaviour of PCM volume control, where the
snd-hda device doesn't work correctly on recent kernels)

Comment 10 petrosyan 2008-07-24 04:17:34 UTC

*** This bug has been marked as a duplicate of 363261 ***


Note You need to log in before you can comment on or make changes to this bug.