Bug 3600 - mouse (gpm) does not work with mc (console)
Summary: mouse (gpm) does not work with mc (console)
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gpm   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 3657 4105 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-20 20:11 UTC by gsromero
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-19 22:04:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gsromero 1999-06-20 20:11:28 UTC
In previos RHs the mouse could be used to select files, etc
in a Midnight Commander console (Linux VC, no X nor telnet).
Currently it work only to select and paste text.

GSR

Comment 1 Jay Turner 1999-06-21 15:01:59 UTC
Confirmed in test lab.  Can only cut-and-paste with the mouse now.

Comment 2 Jay Turner 1999-06-23 15:22:59 UTC
*** Bug 3657 has been marked as a duplicate of this bug. ***

The mc-4.5.30 package shipped with RH 6.0 is compiled
with the wrong gpm version (probably lesser than gpm 1.17
included in the RH 6.0 distributive). Due to this mouse
does not work with mc on the linux text console. The
mc-4.5.30 package must be recompiled with gpm 1.17 libs.
This solves the problem.



------- Additional Comments From jbj@redhat.com  06/23/99 10:19 -------


*** Bug 3658 has been marked as a duplicate of this bug. ***

The mc-4.5.30 package shipped with RH 6.0 is compiled
with the wrong gpm version (probably lesser than gpm 1.17
included in the RH 6.0 distributive). Due to this mouse
does not work with mc on the linux text console. The
mc-4.5.30 package must be recompiled with gpm 1.17 libs.
This solves the problem.

Comment 3 Jay Turner 1999-07-19 13:40:59 UTC
*** Bug 4105 has been marked as a duplicate of this bug. ***

Mouse won't select files or directories.  Looks like it's
just cut-and-pasting. I typed "mc -V" and got no indication
of mouse support on the console, only in Xterms.

It's either this or gpm.

Comment 4 Cristian Gafton 1999-07-28 06:32:59 UTC
assigned to msf

Comment 5 Bill Nottingham 1999-08-19 22:04:59 UTC
should be fixed in the latest mc in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.