Bug 360131 - Auto-generated URL anchors inconsistent between builds
Summary: Auto-generated URL anchors inconsistent between builds
Status: CLOSED DUPLICATE of bug 349361
Alias: None
Product: Fedora
Classification: Fedora
Component: doxygen   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-31 13:08 UTC by Christopher Stone
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 20:20:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Stone 2007-10-31 13:08:35 UTC
When doxygen generates HTML from source code it will sometimes create HTML links
that use auto-generated anchors (e.g., a reference to a member of a class). 
These URLs look like so:

<a class="code" href="classCalVector.html#25802f00441ce192a82463fea4fdfa07">x</a>

I am not sure how the anchor part of the URLs are being generated, but they are
not consistent between builds.  This means that an i386 and x86_64 build of the
same documentation will differ only by the URL anchors that doxygen generates.

This causes a multi-arch conflict.  The documentation should be identical
between arches, but doxygen is causing conflicts because the anchors are
different each time the documentation is generated.

There has to be a way of generating URL anchors in doxygen such that it is
consistent between build times and/or arches.

Please investigate how these URL anchors are generated in doxygen so that we may
assess the feasibility of enhancing doxygen to generate consistent URLs.

Please see bug #340771 as a test case.

Comment 1 Linus Walleij 2007-10-31 20:20:15 UTC

*** This bug has been marked as a duplicate of 349361 ***


Note You need to log in before you can comment on or make changes to this bug.