Bug 36017 - large diskactivity -> kernel freezes
Summary: large diskactivity -> kernel freezes
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-16 10:30 UTC by Dries Verachtert
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 20:25:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dries Verachtert 2001-04-16 10:30:22 UTC
Used system: Personal Workstation 500a MiataGL
  scsi card: QLogic ISP1020 SCSI on PCI bus 01 device 20 irq 27 I/O base
0x9000
  2 harddisks of type RZ2CC-KB (C) DEC Rev: DC2B

When I'm copying a lot of files, the system sometimes hangs. I don't get an
oops or anything. Only thing i still can do is a hard reset.

It only crashes with linux 2.4.x (i'm now using kernel-2.4.2-0.1.49 from
rawhide, whole system is rawhide) The 2.2.x kernels don't have the problem.

Easy reproducable:
dd if=/dev/sda of=/dev/null &
dd if=/dev/sdb of=/dev/null &
and wait 5 minutes

Comment 1 Dries Verachtert 2001-05-24 21:25:13 UTC
the latest patch of Andrea Arcangeli which can be found at 
ftp://ftp.kernel.org/pub/linux/kernel/people/andrea/patches/v2.4/2.4.5pre5aa3/o_direct-7
seems to fix this problem. 

Wesley Daemen is the one who told me this good news. He already applied the 
patch and has started those dd commands to create a lot of harddisk activity 
and his miata doesn't crash.

Comment 2 Dries Verachtert 2001-05-25 13:38:07 UTC
2.4.4-ac17 also seems to have the fix. The fix is contained in the patch of 
Andrea but the original author seems to be  Ivan Kokshaysky.



Comment 3 Dries Verachtert 2001-05-27 15:29:05 UTC
2.4.5 also fixes the problem.

Comment 4 Phil Copeland 2001-05-29 21:15:32 UTC
I believe this is the tbia patch in pci_iommu.c

it's a bit dirty in that as far as I remember the bits to differnetiate between
tbia of 1 and 8 depending on what chipset  you're running (tsunami/clipper are 8
and I think all the rest are 1. I could very well be wrong)

I'm hacking in changes to the 2.4.3 kernel that will be released for 7.1 alpha

Phil
=--=

Comment 5 Dries Verachtert 2001-05-29 22:03:48 UTC
Let me know where i can find the rpms if you want me to test a patched version :-)

Comment 6 Phil Copeland 2001-05-29 22:40:00 UTC
Hopefully rawhide should have kernel-2.4.3-7
That *should* work but probably not for tsunami/clipper motherboards

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.