Bug 360251 - xorg-x11-drv-ati breaks thinkpad brightness key combo
Summary: xorg-x11-drv-ati breaks thinkpad brightness key combo
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-31 14:16 UTC by Josh Boyer
Modified: 2018-04-11 08:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 00:32:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with xorg-x11-drv-ati-6.7.195-2.fc8 (56.65 KB, text/plain)
2007-10-31 17:37 UTC, Josh Boyer
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.7.195-3.fc8 (56.16 KB, text/plain)
2007-10-31 17:39 UTC, Josh Boyer
no flags Details

Description Josh Boyer 2007-10-31 14:16:25 UTC
Description of problem:

On my Thinkpad z60m the FN+Home and FN+End buttons control the brightness level
of the backlight.  A couple weeks ago this stopped working.  I press the key
combos and nothing happens.

I did some bisect of kernels to see if that was the problem, but it wasn't.  I
switched to using the vesa driver instead of the radeon driver and the
brightness key combos worked again.

Then I did a brief bisect of the xorg-x11-drv-ati packages and found that
xorg-x11-drv-ati-6.7.195-2.fc8 worked but xorg-x11-drv-ati-6.7.195-3.fc8 did not.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.7.195-3.fc8

How reproducible:

Always

Steps to Reproduce:
1.  Boot
2.  Try using the FN+Home, FN+End buttons to switch brightness in X
3.  Watch nothing happen
  
Actual results:

The backlight brightness doesn't change

Expected results:

The backlight brightness changes

Additional info:

The brightness key combos work at the grub menu, during kernel boot, and on
vttys but not in gdm or X sessions using the latest radeon driver.

Smolt profile:

http://smolt.fedoraproject.org/show?UUID=63cc2d27-4185-4cc2-bae6-87042b715610

Comment 1 Matěj Cepl 2007-10-31 17:23:51 UTC
Just to be sure that we get info about your hardware correrct, could we get
/etc/X11/xorg.conf and /var/log/Xorg.0.log as well attached to this bug as
separate uncompressed attachments to this bug (sorry, smolt is not that helpful
for Xorg bugs)? Thank you.

Comment 2 Josh Boyer 2007-10-31 17:37:02 UTC
Created attachment 244761 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.195-2.fc8

Xorg.0.log from a working RPM

Comment 3 Josh Boyer 2007-10-31 17:39:54 UTC
Created attachment 244771 [details]
Xorg.0.log with xorg-x11-drv-ati-6.7.195-3.fc8

Xorg.0.log from the broken RPM

Comment 4 Josh Boyer 2007-10-31 17:40:32 UTC
I don't have an /etc/X11/xorg.conf file.  They aren't needed in rawhide/F-8

Comment 5 Josh Boyer 2007-11-12 02:26:11 UTC
Anything I can do here to help this bug?  While reverting to the previous
drv-ati RPM works, F8 was released with the broken one so it would likely be
good to get things fixed.

Comment 6 Josh Boyer 2007-12-04 03:13:28 UTC
This is still present in rawhide:

[jwboyer@vader ~]$ rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.7.195-5.fc9


Comment 7 Josh Boyer 2007-12-20 16:48:34 UTC
Ok, this seems to be fixed now.  Relevant packages:

kernel-2.6.24-0.115.rc5.git5.fc9
xorg-x11-drv-ati-6.7.196-3.fc9
xorg-x11-server-Xorg-1.4.99.1-0.13.fc9

Since this is magically fixed today, I think I'll leave the bug open for a bit
longer in case tomorrows update magically breaks it again ;)

Comment 8 Matěj Cepl 2007-12-20 23:23:42 UTC
OK, let's put this into NEEDINFO, so we won't forget about that, right?

Comment 9 Matěj Cepl 2008-01-21 15:23:11 UTC
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

Comment 10 Josh Boyer 2008-01-21 19:25:21 UTC
Yep, sorry.  I think we can close this out.

Comment 11 Josh Boyer 2008-03-10 13:45:50 UTC
This is back now.

xorg-x11-drv-ati-6.8.0-3.fc9.i386


Comment 12 Josh Boyer 2008-03-10 15:43:17 UTC
Other relevant package versions:

kernel-2.6.25-0.90.rc3.git5.fc9.i686
kernel-2.6.25-0.101.rc4.git3.fc9.i686
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.i386

/sys/class/backlight is empty.  I'll try and see if a kernel can be found that
works with this and check if there are entries in there.  If there's more I can
do to help debug, let me know.

Comment 13 Josh Boyer 2008-03-17 00:32:46 UTC
Ok, whatever.  This is fixed with the latest kernel.  /sys/class/backlight is
still empty, but *shrug*.


Note You need to log in before you can comment on or make changes to this bug.