Bug 360441 - kernel dm: some dm ioctl can fail with 32bit userspace and 64bit kernel
kernel dm: some dm ioctl can fail with 32bit userspace and 64bit kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Milan Broz
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 11:29 EDT by Milan Broz
Modified: 2013-02-28 23:05 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2007-10-31 11:29:05 EDT
Description of problem:

DM-ioctl structure on 32bit on i386 arch has size 308 bytes,
on x86_64 312 bytes.

Some dm ioctl can then fail because of align check in kernel:

/dmsetup.static.32.rhel -vv message mpath 0 fail_if_no_path
dm version   OF   [16384]
dm message mpath  OF  fail_if_no_path [16384]
device-mapper: message ioctl failed: Invalid argument
Command failed

Because dm processing uses own code to checks validity of ioctl struct,
fix can be backported without changing kABI.
Comment 1 RHEL Product and Program Management 2007-10-31 11:35:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Don Zickus 2008-01-08 15:46:41 EST
in 2.6.18-64.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 7 errata-xmlrpc 2008-05-21 10:59:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.