Bug 360461 - [fix available] OpenOffice.Org crashes while editing colours
[fix available] OpenOffice.Org crashes while editing colours
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 11:35 EDT by Mary Ellen Foster
Modified: 2009-04-29 17:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 15:45:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash backtrace (7.67 KB, text/plain)
2007-10-31 11:35 EDT, Mary Ellen Foster
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 83169 None None None Never

  None (edit)
Description Mary Ellen Foster 2007-10-31 11:35:32 EDT
Description of problem:
This has happened twice now while I've been trying to edit the colour palette in
OpenOffice.org -- the program exits and prints a long stack trace (which I'll
attach) to the console where I started the program. This was in Impress both
times, but I don't think that's directly relevant.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Go to "Tools-Options"
2. Choose "Colors"
3. Define and add some new colours (usually happens on about the third or the
fourth one)
  
Actual results:
After pressing "Add", the button appears to freeze pressed in, and then the
program edits printing out the attached backtrace. None of the added colours are
actually successfully saved.

Expected results:
Colours added to the list

Additional info:
Comment 1 Mary Ellen Foster 2007-10-31 11:35:32 EDT
Created attachment 244661 [details]
Crash backtrace
Comment 2 Mary Ellen Foster 2007-10-31 11:42:37 EDT
p.s. -- I actually started the cut-and-paste before the line that said "start
here" because I think the very first thing it prints is interesting:
    ldd: /usr/lib*/openoffice.org2.0/program/libreg.so.3: No such file or directory

There is indeed no such file, but
    /usr/lib/openoffice.org/program/libreg.so.3
exists ...
Comment 3 Caolan McNamara 2007-10-31 12:31:38 EDT
Oh, that's nasty. Still affects F-8 as well. 

I've logged the fix as http://www.openoffice.org/issues/show_bug.cgi?id=83169

It'll be in the first update for F-8 and for F-7 >= openoffice.org-2.3.0-6.5 if
we do such an update
Comment 4 Fedora Update System 2007-12-06 15:45:07 EST
openoffice.org-2.3.0-6.5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Charlie Wyse 2009-04-29 17:01:07 EDT
We are using openoffice.org-2.3.0-6.10.el5 in RHEL5.3 and the problem is still there.
Comment 6 Caolan McNamara 2009-04-29 17:48:22 EDT
No surprise, because they're different branches, and there's a different set of criteria for getting a fix into RHEL

Note You need to log in before you can comment on or make changes to this bug.