Bug 360561 - ps display uid instead of username
Summary: ps display uid instead of username
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-31 17:09 UTC by Daniel Qarras
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 08:38:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Qarras 2007-10-31 17:09:48 UTC
Description of problem:
localhost:~> ps -ef | grep ^68
68        1940     1  0 18:56 ?        00:00:00 hald
68        1982  1941  0 18:56 ?        00:00:00 hald-addon-acpi: listening
localhost:~> grep 68 /etc/passwd
haldaemon:x:68:68:HAL daemon:/:/sbin/nologin

Version-Release number of selected component (if applicable):
procps-3.2.7-17.fc8

How reproducible:
Always

Steps to Reproduce:
1. See above
  
Actual results:
uid printed instead of username

Expected results:
username printed

Additional info:

Comment 1 Tomas Smetana 2007-11-01 08:11:22 UTC
The UID column is hardcoded to be 8 characters wide.  The username 'haldaemon'
can't fit into the UID column and therefore it's "truncated" to the numerical
UID value.  This can't be changed that easily because changing the output format
would be a regression.  The comment in the procps code says:

// The Open Group Base Specifications Issue 6 (IEEE Std 1003.1, 2004 Edition)
// requires that user and group names print as decimal numbers if there is
// not enough room in the column, so tough luck if you don't like it.

This looks to be NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.