Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 3607 - Windows postscript & ghostscript
Windows postscript & ghostscript
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-20 21:00 EDT by degraaf
Modified: 2018-07-06 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-25 18:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description degraaf 1999-06-20 21:00:39 EDT
Postscript data created by Windows drivers contain
%Trailer info not intended to go to the printer.
Ghostscript tries to send this to stdout but the use of the
-sOutputFile=- option combines it and causes an extra page
to follow every job.  This wastes paper and is annoying.

The following construct in
/usr/lib/rhs/rhs-printfilters/ps-to-printer.fpi
corrects this problem:

eval "$mpage_cmd | gs -q -sDEVICE=$GSDEVICE \
      -r$RESOLUTION \
      -sPAPERSIZE=$PAPERSIZE \
      -dNOPAUSE \
      -dSAFER \
      -sOutputFile=\|'cat 1>&3' \
      $COLOR \
      $EXTRA_GS_OPTIONS \
      -  3>&1  1>&2 "
Comment 1 Bill Nottingham 1999-06-23 18:28:59 EDT
what does the %Trailer info look like (I'm trying to sync
this with another report of extra garbage coming from a Windows
postscript driver...)
Comment 2 Bill Nottingham 1999-06-25 18:00:59 EDT
yup, looks like something I've seen before with the
Adobe postscript driver. Fix applied in rhs-printfilters-1.55-1,
in the next Raw Hide release.
Comment 3 Fedora Update System 2018-06-25 05:48:51 EDT
sssd-1.16.2-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5793dadb1d
Comment 4 Fedora Update System 2018-06-26 14:23:41 EDT
sssd-1.16.2-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5793dadb1d
Comment 5 Fedora Update System 2018-07-06 12:42:03 EDT
sssd-1.16.2-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.