Bug 36107 - Incorrect permissions on scripts
Incorrect permissions on scripts
Status: CLOSED ERRATA
Product: Red Hat Powertools
Classification: Retired
Component: cbb (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-16 19:52 EDT by Derek Tattersall
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 19:18:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2001-04-16 19:52:24 EDT
In the /usr/lib/cbb/ and /usr/lib/cbb/reports directories, the perl scripts
and tcl scripts do not have other execute permissions, and as the owner is
root, an oridinary user can't get a listing of his transactions.  This may
also be a problem in other directories under /usr/lib/cbb
Comment 1 Tim Powers 2001-04-18 11:30:57 EDT
I just created a new account, and added a transaction and can view the
transaction fine as a regular user. Where exactly are you seeing problems?

Tim
Comment 2 Derek Tattersall 2001-04-19 05:58:17 EDT
Yeah, no problem with viewing, adding transactions etc.  The problem was
printing.  The perl scripts in the report sub directory of /usr/lib/cbb had no
other execute permissions and could not be executed as a regular user.  Once I
changed them, she could print a report.  Sorry I didn't make it clear in the
beginning.
Comment 3 Tim Powers 2001-04-23 09:41:36 EDT
I have uploaded cbb-0.8.1-8.noarch.rpm to http://people.redhat.com/timp/RPMS,
could you try that package to make sure it works for you?

Tim

BTW, thanks for the report!
Comment 4 Derek Tattersall 2001-04-23 19:18:40 EDT
cbb-0.8.1-8.noarch.rpm  fixed all the problems my wife had.  Prints a report
first time out of the box.  Thanks, Tim.
Comment 5 Tim Powers 2001-04-30 16:45:59 EDT
OK. Errata is out now. I'm resolving this.

Thanks Derik!

Tim

Note You need to log in before you can comment on or make changes to this bug.