Bug 36157 - Kernel lockups under loadavg stress.
Kernel lockups under loadavg stress.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 01:34 EDT by Ed McKenzie
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-04-17 01:34:51 EDT
While creating pathological numbers of threads (to test whether bug 31617
is still an issue), I've managed to lock 2.4.2-2 sporadically. SysRq still
works, but the keyboard seems to lock and the console no longer switches
(all this from a plain VGA text console.)

I couldn't reproduce this on 2.4.2-0.1.49.
Comment 1 Arjan van de Ven 2001-04-18 08:19:12 EDT
Is this a lock or just the kernel being VERY slow ?
Comment 2 Ed McKenzie 2001-04-18 11:27:55 EDT
This was basically a complete lock -- I couldn't switch VT's and the keyboard 
indicators were unresponsive, which I've never seen before at the text console. 
The only thing that seemed to respond was sysrq.

In regards to the original bug report, I've found this pretty difficult to 
reproduce. I've only been able to trigger it twice.
Comment 3 Alan Cox 2003-06-09 11:38:15 EDT
Closing: no reports of this with later errata kernels, if still present please
reopen


Note You need to log in before you can comment on or make changes to this bug.