Bug 36197 - Anaconda crashes on upgrade
Anaconda crashes on upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 05:47 EDT by Arjan van de Ven
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 11:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (10.48 KB, patch)
2001-04-17 05:48 EDT, Arjan van de Ven
no flags Details | Diff

  None (edit)
Description Arjan van de Ven 2001-04-17 05:47:18 EDT
Anaconda python-dumps a lot of errors during either the textmode or
gui upgrade. Log attached
Comment 1 Arjan van de Ven 2001-04-17 05:48:15 EDT
Created attachment 15504 [details]
anaconda dump
Comment 2 Brent Fox 2001-04-17 08:08:41 EDT
What kind of RAID were you trying (0, 1, 5)?  Can you tell me the steps to
reproduce this bug?
Comment 3 Arjan van de Ven 2001-04-17 08:12:03 EDT
Steps: 1) insert floppy 2) poweron 3) select mousetype 4) boom

I was not using RAID at that time as one of the disks was in my other machine :)
It was RAID0 before that.

(eg disklayout:

hda = main disk, 40 Gb
hde = testdisk 1, with 1 raid0 partition from an _oooold_ installation
 	(eg unused for a long time now)
hdg = testdisk 2, 

Comment 4 Brent Fox 2001-04-17 09:33:41 EDT
Ok, I think I see the problem here.  When you do an upgrade, the installer looks
for all existing linux installations, and then gives you the choice of what
partition you want to start the upgrade on.  From looking at the traceback, it
looks like it finds the RAID 0 partition on hde1, but it is looking for the
other raid partition somewhere and it is crashing when it cannot find it.  The
actual error message is totally misleading, however.  I think I can reproduce
this on a test machine.
For a workaround, though, I would recommend removing the RAID partition on hde
and then doing the upgrade.  But anyway, this is a case that we should check for
and do something better than traceback.
Comment 5 Arjan van de Ven 2001-04-17 09:40:52 EDT
agreed. I worked around it by unplugging the disk ;)

Note You need to log in before you can comment on or make changes to this bug.