Bug 362071 - not able tp update kernel.
not able tp update kernel.
Status: CLOSED DUPLICATE of bug 330711
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 12:35 EDT by Adrin Jalali
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 15:18:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2007-11-01 12:35:11 EDT
Description of problem:
I'm using a Dell Inspiron 6400, and to enable Wi-Fi, I installed ndiswrapper and
kmod-ndiswrapper. Everything is good and Wi-Fi works. But when a newer version
of kernel is available, when using yum update kernel, it processes the
kmod-ndiswrapper and kmod-fglrx and decides to install the older version of
kernel, which is the same as installed one and the same as kmod-fglrx and
kmod-ndiswrapper. But it can not find that kernel version on repos. The same
thing happens using yum update kmod-ndiswrapper or yum update kmod-fglrx. My yum
related packages versions are 
yum-refresh-updatesd-1.1.8-1.fc8
yum-fastestmirror-1.1.8-1.fc8
yum-3.2.7-1.fc8
yum-metadata-parser-1.1.2-1.fc8
yum-utils-1.1.8-1.fc8
yum-updatesd-0.7-1.fc8
and kernel version :
kernel-2.6.23.1-35.fc8
kernel-devel-2.6.23.1-35.fc8
kernel-headers-2.6.23.1-35.fc8
and kmod :
kmod-fglrx-2.6.23.1-42.fc8-8.35.3-6.lvn8
kmod-ndiswrapper-2.6.23.1-35.fc8-1.48-14.lvn8
and the available versions of kernel on repos where : 2.6.23.1-42

But when I downloaded last versions of kernel, kernel-devel, kernel-headers,
kmod-fglrx, kmod-ndiswrapper and installed them in the correct order using rpm
-i, they were installed with no errors. And after rebooting the system and
booting with the new kernel, everything was fine.


Version-Release number of selected component (if applicable):


How reproducible:
It's reproducible using those versions I wrote. Currently latest versions.

Steps to Reproduce:
1.Have ndiswrapper and kmod-ndiswrapper and kmod-fglrx installed on your system.
2.Try to update kernel.

  
Actual results:
(I missed the result)
But it said that the dependencis are missing (Because it was trying to find
older versions of kernel)

Expected results:
Work fine and update kernel.

Additional info:
Comment 1 Adrin Jalali 2007-11-01 13:26:20 EDT
there is no need to update ndiswrapper package to make things work fine,
kmod-ndiswrapper update is sufficient.
Comment 2 Tim Lauridsen 2007-11-01 13:41:50 EDT
You have to install the yum-fedorakmod plugin to make the kmod update work right.
Comment 3 Thorsten Leemhuis 2007-11-14 15:18:09 EST
from the slightly unclear description this looks a lot like 330711; closing as dup

(In reply to comment #2)
> You have to install the yum-fedorakmod plugin to make the kmod update work right.

@tim: No, it should work fine without it.


*** This bug has been marked as a duplicate of 330711 ***

Note You need to log in before you can comment on or make changes to this bug.