Bug 36217 - SB Live sounds odd
Summary: SB Live sounds odd
Status: CLOSED DUPLICATE of bug 32723
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL: ftp://opensource.creative.com/pub/sna...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-17 09:57 UTC by Leos Bitto
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 13:35:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leos Bitto 2001-04-17 09:57:28 UTC
After fresh installation of RH 7.1 on my home PC I noticed that my
Soundblaster Live sounds really odd - I cannot hear neraly any basses, etc.
Installing the newest driver (emu10k1.o) from Creative fixes it.

This is how RedHat's driver introduces himself:

Creative EMU10K1 PCI Audio Driver, version 0.7, 20:53:49 Apr  8 2001
PCI: Found IRQ 9 for device 02:0e.0
emu10k1: EMU10K1 rev 4 model 0x20 found, IO at 0xb800-0xb81f, IRQ 9

And this is what Creative's driver says:

Creative EMU10K1 PCI Audio Driver, version 0.12, 11:44:28 Apr 17 2001
PCI: Found IRQ 9 for device 02:0e.0
emu10k1: EMU10K1 rev 4 model 0x20 found, IO at 0xb800-0xb81f, IRQ 9
ac97_codec: AC97  codec, id: 0x5452:0x4103 (TriTech TR28023)

Comment 1 Arjan van de Ven 2001-04-17 10:04:01 UTC
I'm working on this. It appears that the kernel-driver has a "secret" option
to turn on bass, unfortionatly it requires editing the Makefile. I wonder why
it is not enabled by default; I assume some sblive's don't work with the option.


Comment 2 Leos Bitto 2001-04-17 13:35:43 UTC
Maybe you could consider using Creative's newer driver instead. It doesn't have
this "secret" option and works fine in its default configuration. At least for
me. ;) Current situation (with no bass) is simply not acceptable, unless you
want to use the soundcard just as a stupid beeper.

Comment 3 Arjan van de Ven 2001-04-18 15:30:30 UTC
I'll have a look. Anyway, this is basically the same problem as bug #32723 so
I'll mark this as a dupe of that bug to keep the info centralized.

*** This bug has been marked as a duplicate of 32723 ***


Note You need to log in before you can comment on or make changes to this bug.