Bug 3622 - opl3sa2 worked in 5.2, broken in 6.0
opl3sa2 worked in 5.2, broken in 6.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-21 15:30 EDT by benb
Modified: 2014-03-16 22:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-27 18:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benb 1999-06-21 15:30:23 EDT
I have a Dell Dimension XPS H266 with a PnP Yamaha opl3sa2
sound system on the motherboard. With RH 5.2 this worked
fine. With RH 6.0 sndconfig still correctly detects my sound
system, but either the configuration or driver is buggy.
Playback of .wav files works (although volume seems lower
then 5.2), but recording from the microphone has a *VERY*
low volume (was OK in RH 5.2) that can barely be improved
with the mixer panel. I downloaded and tried the commercial
OSS trial version, and this works correctly (the same as RH
5.2 did).
I realize that PnP is an iffy area for Linux, but support
for this sound system is something that DID work, but is now
broken.

Ben
Comment 1 jon.bjorseth 1999-07-02 09:58:59 EDT
I have excactely the same problem.
Whenever I run sndconfig, It will detect my soundcard, I do OK and computer just locks up.
Also I'm experiencing distorted sound when something is printing on screen, or I move the mouse...
Comment 2 cnk 1999-07-06 15:03:59 EDT
I have a rather similar problem - sndconfig worked under 5.2 but not
at all under 6.0. Details of my machine: Dell Dimensions XPS R450,
Crystal PnP Audio system. sndconfig under 5.2 correctly found my sound
system (CS4236B); worked fine with no user intervention. Under 6.0
(with no change in hardware setup), sndconfig find the card correctly
but claims to have a fatal resource conflict with IRQ3 (used by my NIC
card). I tried manual configuration using the values from my working
Win98 setup: IRQ5, registers 0120-7, IRQ10 (for MPU-401 compatability,
but no dice - it then claims a conflict with IRQ10. /proc/interupts/
does not indicate anything using IRQ 5 or 10.
Comment 3 Bill Nottingham 1999-08-18 17:33:59 EDT
One thing to try is upgrading to the latest isapnptools
from Raw Hide; that contains a couple of fixes.

What subtype is the opl3sa2 detected as in 6.0?
Comment 4 slashdot 1999-09-17 00:32:59 EDT
I too have had the same exact experiance using the ESS1868 sound card
, locks the sytem up during sndconfig
Comment 5 Bill Nottingham 1999-09-17 16:45:59 EDT
Does it lock up if you do 'pnpdump -c' from the command line...?
Comment 6 Bill Nottingham 1999-09-24 22:18:59 EDT
One thing to try is the latest isapnptools & sndconfig from Raw Hide;
this fixes at least one known hang in pnpdump.
Comment 7 Bill Nottingham 1999-10-27 18:58:59 EDT
closed, lack of input.

Note You need to log in before you can comment on or make changes to this bug.