Bug 36257 - Can't install from the SCSI CD-ROM I booted from
Can't install from the SCSI CD-ROM I booted from
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 07:46 EDT by John Gotts
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 11:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Gotts 2001-04-17 07:46:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.4.3 i586; Nav)


When I CD-ROM boot Red Hat 7.1, it fails to find the disc it booted from! 
I have an Adaptec 2940U controller.  The drive + disc combo obviously
works, or else I wouldn't have been able to boot into the installer. 
Perhaps installing from the CD-ROM you just booted from only works with IDE
CD-ROM drives, but I can't recall such a limitation in the past.

Reproducible: Always
Steps to Reproduce:
1. Insert CD
2. Reboot
Comment 1 Brent Fox 2001-04-17 08:16:03 EDT
Actually, it is possible that the installer could boot from the cd and then not
be able to find the the data for the second stage install.  I have seen this on
some cd drives before, but I don't fully understand the problem.  I think that
some cd drives have a hard time reading some cd's (especially CD-Rs and CD-RWs)
that go beyond the standard data length.  I think that if you try a different
cdrom drive, things will go ok.  I know that's a pain, though.  I'll look into
this issue further.
Comment 2 Greg Johnson 2001-04-17 11:14:36 EDT
I am having the exact same problem.. Except. I am using the SYM53C8XX based scsi
card with an mmc3 compiliant cdrw. I used it to install redhat 6.2 and 7.0 (on
cdr) and I have been running it with a 2.4.3 kernel without any problems. I
would really really like to install rh7.1! 
I notice something wierd on one of the terminals about unknown iso format and
also I can see it attempt to mount volume on another terminal. 
I am going to grab an old ide cdrom drive from work today to see if it works.
Thanks for your time!
Comment 3 Brent Fox 2001-04-17 11:26:04 EDT
I talked to the guys in QA, and they said that this is a known issue.  Some
motherboard bioses don't support booting off of 2.8 MB boot images, which is
what the cd uses.  What you need to do is make a boot floppy to start the
install, and then it can pull in the cd during the second stage of the install.

You can make a boot disk from the cd with the /images/boot.img with the
following command:
dd if=boot.img of=/dev/fd0 bs=1440k

Then, boot off the floppy and select CDROM when the installation media screen
appears.  This will start the second stage of the install from the cdrom.  This
should work.
Comment 4 John Gotts 2001-04-17 20:06:52 EDT
What BIOS's support booting off these images?  Can you now only install Red Hat
7.1 from the CD on machines less than a year old?  The originally reported
machine has an ASUS P5A-B motherboard with a BIOS update dated 5/31/2000.
Comment 5 Need Real Name 2001-10-17 00:20:35 EDT
DELL PowerEdge 4300
2 x Pentium III 500 Mhz
Adaptec 7896 SCSI CTL
Adaptec 2100S RAID CTL

Boot from Redhat Linux 7.1 CD 1 in CD-ROM drive.  Enter "expert" at initial boot prompt.  "Yes" to load 2100S RAID driver from floppy. 
 Load of driver is successful but after selecting language and keyboard, the prompt for device to install from doesn't show the 
CD-ROM, only the hard disk.  Following these steps but choosing not to install the RAID driver seems to work fine, except that when 
the install gets to the point where it checks for disks there are none because the RAID driver isn't loaded

Note You need to log in before you can comment on or make changes to this bug.