Bug 362721 - rhgb crashes on first boot, leaving system stuck on stippled X startup screen
Summary: rhgb crashes on first boot, leaving system stuck on stippled X startup screen
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rhgb   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-11-01 22:11 UTC by Will Woods
Modified: 2013-01-10 04:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 15:34:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Will Woods 2007-11-01 22:11:29 UTC
Booting a freshly-installed F8 (rc3) system, X comes up on the stippled screen,
then seems to crash, then starts again, then hangs there. 

Rebooting the system will allow it to start normally on the next boot.

< notting> f13: so, stipple of doom is:
< notting> - rhgb fails
< notting> - firstboot tries to start its own x server
< notting> - something goes wonky where firstboot exits, but x server keeps
running on *vt6*
< notting> - mingetty starts on *vt6*
< notting> - x server is now fubar

I think this also affects the Live images, although slightly differently. rhgb
never manages to start, but since there's no firstboot we end up in GDM. Which
works fine, somehow.

Comment 1 Jeremy Katz 2007-11-02 01:07:56 UTC
"Fixed" with a rhpxl tweak so that we don't hit an exception in the Xserver
startup path and things then go fine.  This is related to the rhgb funnies, though.

Leaving open for that (as they still cause other problems)

Comment 2 Will Woods 2007-11-02 05:09:25 UTC
We're building new (rc4) images that will contain this fix.

Comment 3 Will Woods 2007-11-02 17:08:07 UTC
With the rhpxl tweak and rhgb reverted to rhgb-0.17.7-3.fc8, rhgb is confirmed
to be working OK in RC4 images. Yay! That makes this not-a-blocker.

Leaving the bug open since, as Jeremy said, we're still not sure what was
causing rhgb-8.0.2-1.fc8 to fail in the first place.

Comment 4 Adam Jackson 2008-02-12 15:34:33 UTC
rhgb8 never shipped, dutifully ignoring this bug.


Note You need to log in before you can comment on or make changes to this bug.