Bug 36301 - oops when ifup on a pcnet32 based interface
oops when ifup on a pcnet32 based interface
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 13:40 EDT by Norm Murray
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 01:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norm Murray 2001-04-17 13:40:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22smp i686)


When ifup'ing a pcnet32 based interface with the pcnet32 module not loaded
the following oops results:
Unable to handle kernel paging request at virtual address c888ee40
 printing eip:
c01aa65d
pgd entry c4c70c88: 00000000007c92063
pmd entry c4c70c88: 00000000007c92063
pte entry c7c92238: 00000000000000000
... pte not present!
Oops: 0002
CPU:    0
EIP:    0010:[<c01aa65d>]
EFLAGS: 00010246
eax: c888ee40   ebx: c889a000   ecx: 00000000   edx: c113ed20
esi: c889ce40   edi: 00000000   ebp: 080a0188   esp: c4ab5f08
ds: 0018        es: 0018        ss: 0018
Process modprobe (pid: 1741, stackpage=c4ab5000)
Stack:  c889a000 00000000 00000000 c889c0d2 c889ce40 c889a000 00000000
00000000
	080a0188 c011a3b5 00000000 c4d0c000 00002e80 c4d0d000 00000060 ffffffea
	00000007 c65c0de0 00000060 c8890000 c889a060 00002ff0 00000000 00000000
Call Trace: [<c889a000>] [<c889c0d2>] [<c889ce40>] [<c889a000>]
[<c011a3b5>] [<c8890000>] [<c889a0\60>]
    	[<c01091cb>]

Code: 89 30 8b 1d a8 a0 28 c0 81 fb a8 a0 28 c0 74 23 8d 76 00 53




Reproducible: Always
Steps to Reproduce:
1. Boot system
2. ifdown interface
3. rmmod pcnet32
4. ifup interface
	

Actual Results:  lsmod shows the pcnet32 module in initializing state
system is not totally hung


Additional information: This nic is built in on several motherboards
including the IBM eServer xSeries 340
Comment 1 Arjan van de Ven 2001-04-17 13:46:41 EDT
This sounds like the driver leaves the interface "alive" after rmmod.
I'll look into this.
Comment 2 Need Real Name 2001-04-25 01:41:26 EDT
Looks like an identical message with IBM PC-Server 325 with onboard AM79C790 
ethernet.  I was trying to upgrade from 6.2 to 7.1 - I ended up falling back 
to 7.0 (2.2 kernel, not 2.4 kernel) which works fine except for the X display.

My error is just slightly different, attached here just in case it helps (I 
was using insmod, not ifup):

Unable to handle kernel paging request at virtual address c887ee40
printing eip:
c01aa65d
pgd entry c62d1c88: 0000000007c9d063
pmd entry c62d1c88: 0000000007c9d063
pte entry c7c9d1f8: 0000000000000000
... pte not present!
Oops: 0002
CPU:    1
EIP:    0010:[pci_register_driver+29/96]
EIP:    0010:[<c01aa65d>]
EFLAGS: 00010246
eax: c887ee40   ebx: c8884000   ecx: 00000000   edx: c027bd18
esi: c8886e40   edi: 00000000   ebp: 080763d8   esp: c62d3f08
ds: 0018   es: 0018   ss: 0018
Process insmod (pid: 943, stackpage=c62d3000)
Stack: c8884000 00000000 00000000 c88860d2 c8886e40 c8884000 00000000 00000000 
     080763d8 c011a3b5 00000000 c6294000 00002e80 c6295000 00000060 ffffffea 
     00000007 c6eefca0 00000060 c8880000 c8884060 00002ff0 00000000 00000000 
Call Trace: [ipchains:__insmod_ipchains_S.bss_L1072+53696/30003232] 
[ipchains:__insmod_ipchains_S.bss_L1072+62098/29994830] 
[ipchains:__insmod_ipchains_S.bss_L1072+65536/29991392] 
[ipchains:__insmod_ipchains_S.bss_L1072+53696/30003232] 
[sys_init_module+1349/1584] 
[ipchains:__insmod_ipchains_S.bss_L1072+37312/30019616] 
[ipchains:__insmod_ipchains_S.bss_L1072+53792/30003136] 
[<c8884000>] [<c88860d2>] [<c8886e40>] [<c8884000>] [<c011a3b5>] [<c8880000>] 
[<c8884060>] 
       [system_call+51/56] 
       [<c01091cb>] 

Code: 89 30 8b 1d a8 a0 28 c0 81 fb a8 a0 28 c0 74 23 8d 76 00 53 

Comment 3 Arjan van de Ven 2001-04-26 08:07:36 EDT
We hope to have fixed this in the latest nightly build. I hope it will be
available in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.